SipStation DID not being redirected | SPA-3102

Hi all,

I’m running freePBX-2.7.0-10, extensions, conferences and ring groups working as is supposed to.
I bought a trunk from sipstation and DID number.

I’m having troubles with this DID being redirected to an existing extension.
The issue presents when I redirect the DID to an extension that is
connected to a Linksys/Sipura SPA-3102.
Linksys SPA-3102 is registered and working ok (both line 1 and pstn line), the pstn line associated with it also works ok because I can call in from another
extension and get line.
The DID has no problem at all if I redirect it to a “normal” extension
(even the common line at the Linksys), also if i redirect it to a
Conference number it also works ok.
Any ideas why this isn’t working?
Any thoughts would be greatly appreciated.
Thanks in advance.

Agustín

Thanks Barry, i did learn quite a bit from this :wink:
Regarding the clearness of both our sip trunks used, i must say sipstation goes ahead.
I’ve been using 12Voip sip trunk for quite a long time and there’s big difference in the service (with sipstation i cannot tell if the call is going over IP or standard PSTN ). I also have to be fair and say that 12Voip has 90 days freedays to US calls and you can tell when the service goes over that period, i think the might have some kind of priority of course.
But comparing both service when they’re paid (12voip case) i would say sipstation takes the lead.
I’ve also used voipbuster service and is the same as 12voip, i simply choose 12voip because of some free destinations.
I hope it helps.

Agustin

Agustin,

Glad you got your SPA3102, inbound, outbound calls working! Regardless how long you have used Asterisk the matching dial patterns in conjunction with trunking can be a real head scratcher,:slight_smile: I am sure you learned quite a bit from all of this in the process in regards to debugging a call…
Curious. Is your calls on both of your sip trunks clear on all of your extensions? I always wonder who has good reliable trunks.

Take Care,
Barry

Ok, i enabled sip debbuging and read a lot of logs :wink:
Finally, i realized that i wasn’t testing the right way :frowning:
I have 2 sip trunks to reach US numbers (one from sipstation and one from 12voip)
I was testing this way:
dialing from my softphone at home to DID number (sipstation), this goes out from sipstation (because the outbound route matched before) , then i assumed that i can’t use the trunk both for outgoing and incoming calls, so that’s the problem i guess.

I changed the outbound route to match this only DID number so i can go out from 12voip instead, and this way worked for me.

This is the problem not living in the states and be able to call just from my home phone :stuck_out_tongue:
Also i asked a friend living in the US to give me a call to that DID number and worked just fine too.

I wanted to thanks both Philippe and Barry for your time. I promise to check my testing scenarios next time.

Agustin

turn on sip debugging and see who is asking for the call to be dropped.

Hi p_lindheimer, i have setted up G711u as my preferred audio codec to avoid that kind of issues. Also i know from sipstation trunk config that sipstation uses both ulaw & g729, so they should negotiate u-law right? See SPA-3102 PSTN Line status below, my guess is both are using u-law.

The call seems to establish (just a ring and then silence) because twinkle (the softphone that im using to troubleshoot) shows line 1 status as established.
Also from the asterisk logs i get:

[Feb 21 14:20:58] VERBOSE[18269] app_dial.c: – SIP/8000-000000de is ringing
[Feb 21 14:20:58] VERBOSE[18269] app_dial.c: – SIP/8000-000000de answered SIP/fpbx-1-usernamehere-000000dd
[Feb 21 14:20:58] VERBOSE[18268] app_dial.c: – SIP/fpbx-1-usernamehere-000000dc is ringing
[Feb 21 14:20:58] VERBOSE[18268] app_dial.c: – SIP/fpbx-1-usernamehere-000000dc answered SIP/8164-000000db
[Feb 21 14:20:58] VERBOSE[18268] rtp.c: – Packet2Packet bridging SIP/8164-000000db and SIP/fpbx-1-usernamehere-000000dc

And then after a few seconds call drops, and asterisk log says:
[Feb 21 14:21:38] VERBOSE[18269] pbx.c: – Executing [[email protected]:1] Macro(“SIP/fpbx-1-usernamehere-000000dd”, “hangupcall”) in new stack
[Feb 21 14:21:38] VERBOSE[18269] pbx.c: – Executing [[email protected]:1] GotoIf(“SIP/fpbx-1-usernamehere-000000dd”, “1?noautomon”) in new stack
[Feb 21 14:21:38] VERBOSE[18269] pbx.c: – Goto (macro-hangupcall,s,3)
etc , etc

This is the PSTN Line Status report from SPA-3102 when call is established:

STN Line Status
Hook State: On
Line Voltage: -48 (V)
Loop Current: 0.0 (mA)
Registration State: Registered
Last Registration At: 2/21/2011 13:20:58
Next Registration In: 282 s
Last Called VoIP Number:
Last Called PSTN Number:
Last VoIP Caller:
Last PSTN Caller: ,
Last PSTN Disconnect Reason:
PSTN Activity Timer: 300000 (ms)
Mapped SIP Port:
Call Type:
VoIP State: Connected
PSTN State: Idle
VoIP Tone:
Outside Dial
PSTN Tone:
VoIP Peer Name: Phonebooth
PSTN Peer Name:
VoIP Peer Number: usernamehere
PSTN Peer Number:
VoIP Call Encoder: G711u
VoIP Call Decoder: G711u
VoIP Call FAX: No
VoIP Call Remote Hold: No
VoIP Call Duration: 00:00:11
VoIP Call Packets Sent: 1141
VoIP Call Packets Recv: 0
VoIP Call Bytes Sent: 91280
VoIP Call Bytes Recv: 0
VoIP Call Decode Latency: 0 ms
VoIP Call Jitter: 0 ms
VoIP Call Round Trip Delay: 0 ms
VoIP Call Packets Lost: 0
VoIP Call Packet Error: 0
VoIP Call Mapped RTP Port: 8130 >> 0

check you logs, you may have a codec issue such as the SPA3102 forced to g729 and no transcoding license on your server.

The log should indicate if anything like this is going on.

Agustin,

To troubleshoot. Create a brand new extension number in freepbx. One that is not currently in any of your ring group settings. Assign this new extension to your SPA-3102 ( temporarily).Assign your sipstation did to ring to this new extention number(SPA-3102).
See if it will ring into the SPA-3102 this way. If it does ring in something is wonky in your ring group setting.
This will narrow things down somewhat.

Barry

Hi Barry, thanks for you answer.
The actual extension that is associated to DID number is not part of any ring group.
To clarify just a bit, line1 extension of spa-3102 it is part of a ring group but pstn line extension isn’t, so i think I’m in the setup you mentioned.
I’ll give it a try though, just to make sure ring groups aren’t bothering. Thanks again.
Another note is that SPA-3102 is configured to
VoIP Caller Auth Method = None so as soon as someone rings in this extension it gives pstn line without asking for a pin or anything. I’ll keep this setting this way until i can troubleshoot why DID isn’t ringing this extension.

Agustin