SIPSTATION - CIsco 7962 config issue


#1

Good day

I am trying to figure out how to make SIPSTATION and Cisco phones work on the same freepbx server

in order to get the cisco phones to register to the network and not on a continuous bootloop. I had to
add [233](+) force_rport = no to the Sip config. this caused connectivity issues with SIPSTATION I can make calls with no audio, and no one can call in on this number. If I delete the [233](+) force_rport SIPSTATION works great, however, the phone will not connect.

Question how can I get both of these up and running?


#2

Here is what the SIPSTATION is telling me


(Lorne Gaetz) #3

I presume that extension 233 is your Cisco extension? If so add the lines to the file /etc/asterisk/sip_custom_post.conf like this:

[233](+)
force_rport=no

#4

Thanks for the reply, I am not sure what 233 ism it is definitely not an extension. My extensions are from 201 thru 224 all of them are Cisco 7962 this code works for all of them.

This was a fix a read in another form and tried and it worked.


(Lorne Gaetz) #5

Well I can’t imagine that putting Other SIP Settings in the way you are will work. Have you tried setting the NAT mode to force_rport when you edit the Extension:


(Andrew Nagy) #6

The way you wrote that setting in there is causing asterisk to read an invalid configuration which is then causing sipstation to have issues.

Do what @lgaetz suggested and remove what you wrote


(Tom Ray) #7

@wadehinshaw5235

For the record, Additional SIP Settings adds SIP Settings to the [general] context for sip.conf, ie global settings that impact all the Chan_SIP peers, endpoints or trunks. What you are looking to do is a template which requires its own context. So it should go in sip_custom_post.conf like lgaetz pointed out.


#8

copy all, call me a newbiee still figuring this out. thanks for the clarification. and info!