Sip trunk with realm, how?

Oure sip trunk provider are moving os to a new set up.
I need to make a new Sip trunk with credentials like this:

server: sip,host,xx
user: username
realm: doamin,xx
Password: password

I can not get oure server to registre against sip,host,xx. It will not send the correct realm in theProxy Auth.

I use this registration string:
username:[email protected],host,xx/usertrunk
Result:
Proxy-Authorization: Digest username=“username”, realm=“null”, algorithm=MD5, uri=“sip:sip,host,xx”

and tried with this:
[email protected],xx:[email protected],host,xx/usertrunk
Result:
Proxy-Authorization: Digest username=“username”, realm=“doamin.xx”, algorithm=MD5, uri=“sip:domain,xx”

The provider tells my to add the realm under Outbound Proxy. But how in asterisk?

I’m currently testing with newest FreePBX

Normally, the provider supplies the realm in the WWW-Authenticate header of the 407 response. It’s not something that the user would set directly.

Do you have a working connection using a softphone (Zoiper, MicoSIP, PhonerLite, Linphone, …) connecting directly to the provider? If so, post all non-default settings and we can suggest the equivalent settings for a pjsip trunk. Of course, redact username and password but keep the format intact.

For example:

Server: sip.example.com
Username: 12345678
Password: abcdefgh
Outbound Proxy: sip.otherdomain.com

If the username (or authuser, if different) has an @ followed by a domain name, make that clear.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.