SIP Trunk setup issues. No inbound calls due to no registration

I have an extensive IT background, but I’m new to FreePBX and still learning CentOS. I have FreePBX 2.11.0.11 running on CentOS 6.4 (all installed via PIAF2 2.0.6.4.5 64BIT). I have reloaded the whole machine with the same results. Working with my ISP and SIP trunk provider who “Doesn’t support Asterisk due to the many different flavours available”, I know the account work by setting it up on an X-Lite softphone and a Yealink IP handset, and it works on both. As for my FreePBX install, I can have extensions call each other over my LAN with perfect results. Any extension can call out to a PSTN phone number, and the call is perfect. The trouble is, I can not recieve any inbound calls. The phone dialing in recieves a “Fast Busy” signal. Checking with the SIP Trunk provider, they are not seeing any registration attempts from my IP (Static Public IP with the proper inbound port forwarding configured). They provided me with “Asterisk setup advice” as per other clients that have set it up, however they are not directly supporting me on this.
Here is their “advice”…

The Asterisk PBX can and is being used on the Galaxy network but due to the myriad of permutations with varying versions, OS support issues and customized configurations, Asterisk is not officially supported.

However, the following example sip.conf is provided to help get started (based on the example VoIP number: 200112345678 with password: abc123):


[general]
srvlookup=yes

register => 200112345678:[email protected]/200112345678
registertimeout=60
registerattempts=0

[authentication]
[200112345678]
type=peer
secret= abc123
username=200112345678
host=ep.asterisk.rgns.net
fromuser=200112345678
outboundproxy:15061=ep.asterisk.rgns.net
insecure=invite
context=default
disallow=all ; Note: In user sections the order of codecs listed with allow= does NOT matter!
allow=ulaw
allow=g729
qualify=yes
qualifyfreq=40


The @200112345678 portion of the register line references the context [200112345678]. The settings under [200112345678] will be used for registration and in turn the same settings under [200112345678] can be used to for outbound calls, sourced from extensions.conf. The appending /200112345678 of the register line is the extension, this will allow the Asterisk box to register with a Contact of 200112345678 and in turn you can create an extension of 200112345678 in extension.conf to receive calls, ie:

[default]
exten => 200112345678,1,Goto(some_extension,1,1)

[some_extension]
exten => 1,1,Wait(1)
exten => 1,2,NoOp(${CALLERID(all)})
exten => 1,3,background(/var/lib/asterisk/sounds/greeting)
exten => 1,4,Dial(SIP/101,20)

Note: If asterisk has difficulty looking up DNS SRV records, try changing the outboundproxy to: outboundproxy:15061=ep.asterisk.rgns.net

So I have been able to rule it down to my FreePBX box being the issue. I have tried all of this from my network, as well as I moved the PBX box and phones to my local ISP’s office, where they let me troubleshoot at a desk there. I know that it isn’t a network config issue… it is something in the FreePBX setup.
My SIP Trunk provider has not seen any traffic from my IP to their’s trying to register. Today, I SSH’ed into my box and ran a “sip reload” which came up with…

[2013-12-18 12:31:11] WARNING[1785]: sip/config_parser.c:132 sip_parse_register_line: Format for registration is [peer?][transport://]user[@domain][:secret[:authuser]]@host[:port][/extension][~expiry] at line 25

[2013-12-18 12:31:11] WARNING[1785]: sip/config_parser.c:812 sip_parse_nat_option: nat=yes is deprecated, use nat=force_rport,comedia instead

[2013-12-18 12:31:11] WARNING[1785]: sip/config_parser.c:132 sip_parse_register_line: Format for registration is [peer?][transport://]user[@domain][:secret[:authuser]]@host[:port][/extension]
[~expiry] at line 8

[2013-12-18 12:31:11] SECURITY[1749]: res_security_log.c:134 security_event_cb:SecurityEvent=“RequestBadFormat”,EventTV=“1387387871-530801”,Severity=“Error”,Serrvice=“AMI”,EventVersion=“1”,SessionID=“0x28da5f8”,LocalAddress=“IPV4/TCP/0.0.0.0/5038”,RemoteAddress=“IPV4/TCP/127.0.0.1/42201”,RequestType=“Action: ZapShowChannels”,SessionTV=“1386679247-879539”,AccountID="admin

I'm sure there is enough info here to pick out some mistake that I have made. Just to recap... Extension to extension calls are perfect. Extension out on the trunk works as it is listed as a "PEER", and the inbound calls simply get a fast busy on their phone, which corresponds to my SIP Trunk provider not having a client registered to that account. Using a SIP phone direct to my SIP trunk provider works and registers just fine. It really seems to boil down to FreePBX simply not even trying to register. Any help would be great. This is driving me to drink!

You need to show us what you put in FreePBX trunk settings.