SIP trunk registration

Hi, I’m using Freepbx 2.10/Asterisk 1.8, and through the GUI I have entered the following information corresponding to my trunk:


Registration String:
1777xxxxxxx:[email protected]/1777xxxxxxx

I also have extensions set up, and the extensions are working perfectly. I can call callcentric numbers and other extensions in the PBX. My problem is that incoming calls from other callcentric numbers aren’t getting forwarded to the extensions.

I have an inbound route configured as so:

Description: Incoming Callcentric
DID number: 1777xxxxxxx (the same number used in the trunk)
Destination: Extension 1000

But like I stated, incoming calls from another callcentric number aren’t getting forwarded to the extension.

This configuration was set up using instructions provided by callcentric’s webpage. One thing I noticed is that “sip show registry” in CLI does not show any registered trunks. “sip show peers” does in fact show the callcentric trunk, and the FreePBX System Status shows 1 trunk online, but all other information I’ve read about states that any registered trunk should appear under the “sip show registry” command. Is the trunk really supposed to appear under the “sip show registry” command? If anyone knows why and/or how I can get it working properly, I would appreciate it.

EDIT: I added the registration string to the [general] section in “sip.conf” and the registration worked, but once again, shouldn’t it have worked automatically with the FreePBX GUI? It kind of defeats the purpose of having a GUI if you have to edit the files manually…

Hi, can you post the result of an incoming call (if at all it does come in)

1777xxxxxxx:[email protected]/1777xxxxxxx

Would like to know if any calls are coming in at all?

As you said, sip show registry need to work if that’s how incoming calls are recommended by the provider. Try creating a new trunk with just the registration and no outgoing setting (removing this one)

It would probably need to show up, otherwise i believe it may not work.