SIP Trunk Provider is Saying my Outbound Number is Unknown

I have been working on setting up a CNAM/CID for all of my outbound calls. I have successfully setup this with my SIP trunk provider (flowroute), but in doing some troubleshooting they are saying my outbound number is “unknown”. Here is the comment from the flowroute support:

"We are seeing the LEI Oregon in the from but since the number is set to Unknown then it changed to Unavailable. Please make sure that the outbound number is set to 5033993828 instead of Unknown. We have verified that the number 5033993828 returns LEI Oregon in the national database. "

I’ve been digging around in my outbound route settings and the trunk settings and I can’t see where to set the outbound number. Can someone please point me in the right direction?

Thanks!

Make sure you set a caller ID on the extension you are making calls from, and that you aren’t overriding the caller ID in any outbound routes or trunks.

For your extension, set Outbound CID to
"LEI Oregon" <15033993828>
punctuated exactly as above, then test. Flowroute assumes that the number in the From header starts with the country code (leading + is optional).

Thanks so much. I am getting closer. The calls are not being blocked as private any longer, but the CNAM “LEI Oregon” isn’t showing up on the receiving end when I call my cell phone. Just my outgoing number, which is definitely better than it was.

Here is what the CNAM is I have set it flowroute:

image

Here is what’s showing in the asterisk log:

[2021-04-09 10:20:45] VERBOSE[19689][C-00000025] pbx.c: Executing [[email protected]:34] Dial(“SIP/103-00000043”, “SIP/US West OR Flowroute/15415218449,300,Tb(func-apply-sipheaders^s^1,(6))U(sub-send-obroute-email^15415218449^15415218449^6^1617988845^LEI OREGON^15033993828)”) in new stack

Again, I’m just not seeing the cnam show up on the receiving end. Note: I also use the CID setting exactly as you list above.

A lookup on SignalWire indeed shows LEI OREGON.

On your mobile, if the number is in your contact list, it will generally prefer that name to what the network sends. Some phones have a setting to prefer the network value.

Some MVNOs don’t do CNAM lookups at all, so you will see only the number, or the name from your contacts.

If you want to confirm that your CNAM value has properly propagated to the ‘official’ Neustar database, call an AT&T or Verizon landline and ask them what name was displayed.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.