SIP Trunk Prover not getting "404 Not Found" when Inbound Route is not present

When the SIP Trunk provider sends us a call that is not present in the “Inbound Routes”, they do not receive a “404 Not Found”. They still get the “200 Go Ahead” response.

My SIP Trunk Settings are;

host=“provider URL”

I can make and receive calls, but for some reason, if the provider sends me a call that is not currently programmed in the Inbound Routes, they receive a 200 response, not a 404.
The provider has a feature that sends the call to another number when the can’t reach it through our system and that is why they are sending us the call in the first place. T
The problem is that they should get a 404 response so that their “Surecall” feature takes over and redirects the call and they are not.

PBX Firmware: 12.7.6-1904-1.sng7
PBX Service Pack:
Current Asterisk Version: 13.22.0

This is a Production System, so i can not perform any upgrades at this time, but I doubt that would be needed. I think there is a setting i am missing, but I don’t know what it is.

Can anyone help me please?


Do you specifically require a 404, or will other response codes work? If you create an inbound route and set the destination as ‘Terminate Call’, the various options available are:
Hangup 603
Congestion 503
Busy 486

I’ve been looking for a way to do 404, and haven’t been able to find one. If there is a specific Asterisk dialplan Application that can do it (there may not be), you could create your own dialplan, reference with a Custom Destination and set the inbound route to this custom dest.

Hi Lorne,

Thank you for the quick reply.

This will work.
Do I need to create an Inbound Router for each Specific DID that I don’t want to pass?


Either that, or create an ANY/ANY route with no CID/DID specified such that all calls without a specifically defined DID route go to Terminate Call.

Thank you very very much.
This has solved the problem.

You are a rcok star my friend.


1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.