SIP trunk incoming calls setting help needed!

Hi,
I created one sip extension 1234 in server A and register one SIP trunk in Server B, and all the international calls of Server B are through Server A, now i want the server A can call this extension 1234 and server B will anser it with the created DID incoming call destination

What i did is under Server B
–Incoming Router,
set DID to 1234
Set destination to extension registered to Server B

–SIP Trunk
–Outgoing settings
ignored as the outbound call from server B to server A is fine
–Incoming Settings
-User context from-trunk (randomly set)
-User Details
allow=g729&ulaw&alaw&gsm
canreinvite=no
context=from-trunk
disallow=all
fromdomain=Server A IP
fromuser=67345792
host=Server A IP
notransfer=yes
secret=12345
type=user
username=1234

Register String
[email protected] A IP/1234.

However, once i want to call extension 1234 from extension registered to Server A, it always shows “everyone is busy/congested this time”, By right i should be able to do the following
Other extension from Server A ==> call extension 1234 ==>incoming call of server B
==> DID call to the specified destination of Server B.

any one pls help me on this? i am totally lost…

johnny