SIP Trunk Configuration Help

I have a SIP trunk that was setup by TDS. They install a local cisco box that allows the PBX to connect locally without authentication. I have gotten a version of xlite to connect very simply to the system and hope someone can give me some guidance in getting the PBX to work as well. I installed xlite and the only settings I needed to change or set were User ID, Domain, and Authorization Name on the account tab. I also had to set the SIP signaling port to 5060 on the topology tab. Can someone help with what I might need on the PBX?



IS the Cisco the gateway for the PBX?

You need only one peer for both inbound and outbound (leave the second peer blank in the trunk)

host=ip of carrier switch
fromdomain=the domain
username=authorization name

From that point you can tweak DTMF and CODEC settings once it is working.

When you post always include FreePBX version, Asterisk version and how the system was installed (by hand or distro)

Sorry about not including the info. I am running the freepbx distro. Version 5.211.65 with asterisk 11. This was installed off the distro. I am in the process of replacing a trixbox system version with this. I have tried these settings on either system and it doesn’t seem to connect for incoming calls. The Cisco is both the WAN gateway on the router and the SIP gateway for the PBX.

Turn on SIP debug to your carrier in Asterisk and see what response they are sending back when you try and make a call. It could be not a SIP issue but the number of digits you are sending and/or the caller ID you are sending.

You say inbound works so I assume you can ping the carriers SIP server from the FreePBX box?

When you configured the X-lite did you specify the IP address of the CISCO router or the IP address of the providers remote gateway? Is the CISCO router acting as a SIP proxy? Can you post your trunk config?

Neither inbound or outbound calling works. The cisco is not acting as a proxy, but instead is the actual gateway. Xlite is setup to pass traffic to the CISCO IP of The following is how the sip trunk is setup


I believe there is also a problem with the context causing issues on the incoming calls as I get the following message in asterisk CLI when I receive a call

[2014-04-22 09:35:10] NOTICE[1831][C-00000008]: chan_sip.c:25450 handle_request_invite: Call from ‘8479960103’ ( to extension ‘8479960103’ rejected because extension not found in context ‘inbound-from-TDS’.

I have fixed the problem with the SIP trunk on outgoing. I had to force the port which I apparently did not do. It works now, but I am still getting the context error on incoming. The calls do make it to the PBX, but don’t route correctly.

Debug line from incoming call.

[2014-04-22 09:53:27] NOTICE[1831][C-0000000b]: chan_sip.c:25450 handle_request_invite: Call from ‘8479960103’ ( to extension ‘8479960103’ rejected because extension not found in context ‘inbound-from-TDS’.
Scheduling destruction of SIP dialog ‘[email protected]’ in 32000 ms (Method: INVITE)

<— SIP read from UDP: —>
ACK sip:[email protected]:5060 SIP/2.0
Via: SIP/2.0/UDP;branch=z9hG4bK1682169
From: “SYSTEM ASSOCIAT” sip:[email protected];tag=426E06C-D5C
To: sip:[email protected]:5060;tag=as29e5a547
Date: Tue, 22 Apr 2014 14:53:27 GMT
Call-ID: [email protected]
Max-Forwards: 70
CSeq: 101 ACK
Allow-Events: telephone-event
Content-Length: 0

The context needs to be from-trunk you can’t just make up context names.

Thank you. I was putting the context from a config guide they provided. I missed that.