SIP Trunk / 407 Proxy Authentication Required / BroadVox

I have s SIP trunk from BroadVox that works fine for outbound calls but incoming calls are getting rejected with a 407 Proxy Authentication Required. I have searched on this and think I have done every solution that I found so am in need of assistance! Any help would be greatly appreciated

To avoid any NAT issues this box is currently setup outside for testing purposes.

Incoming Settings:

User Context: xxxxxx1517 (BroadVox BTN/Number)
User Details:
type=user
context=from-trunk
insecure=invite **Have also tried “very”

The one thing that I noticed that seemed weird to me was that the one of the INVITE and (later) a CONTACT tags show an “[email protected]” – I was thinking that should be something like the DID.

INVITE sip:[email protected]:5060 SIP/2.0

SIP DEBUG:
<— SIP read from 209.249.3.59:5060 —>
INVITE sip:[email protected]:5060 SIP/2.0
Max-Forwards: 69
Session-Expires: 3600;refresher=uac
Supported: timer, 100rel
To: sip:[email protected]:5060
From: sip:[email protected];tag=3447630969-781005
P-Asserted-Identity:sip:[email protected]:5060
Call-ID: [email protected]
CSeq: 1 INVITE
Allow: INVITE, BYE, OPTIONS, CANCEL, ACK, REGISTER, NOTIFY, INFO, REFER, SUBSCRIBE, PRACK, UPDATE
Via: SIP/2.0/UDP 209.249.3.59:5060;branch=z9hG4bK7a001eed94cd4cfa02d2806d9277e027
Contact: sip:[email protected]:5060
Call-Info: sip:209.249.3.59;method="NOTIFY;Event=telephone-event;Duration=1000"
Content-Type: application/sdp
Content-Length: 250

v=0
o=NXT02 19868 14247 IN IP4 209.249.3.59
s=sip call
c=IN IP4 209.249.3.60
t=0 0
m=audio 10454 RTP/AVP 0 18 101
a=rtpmap:0 PCMU/8000
a=sendrecv
a=rtpmap:18 G729/8000
a=fmtp:18 annexb=no
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-15

<------------->
[Apr 1 17:02:08] VERBOSE[17205] logger.c: — (15 headers 12 lines) —
[Apr 1 17:02:08] VERBOSE[17205] logger.c: Sending to 209.249.3.59 : 5060 (no NAT)
[Apr 1 17:02:08] VERBOSE[17205] logger.c: Using INVITE request as basis request - [email protected]
[Apr 1 17:02:08] VERBOSE[17205] logger.c: Found peer ‘BroadVox1’
[Apr 1 17:02:08] VERBOSE[17205] logger.c:
<— Reliably Transmitting (no NAT) to 209.249.3.59:5060 —>
SIP/2.0 407 Proxy Authentication Required
Via: SIP/2.0/UDP 209.249.3.59:5060;branch=z9hG4bK7a001eed94cd4cfa02d2806d9277e027;received=209.249.3.59
From: sip:[email protected];tag=3447630969-781005
To: sip:[email protected]:5060;tag=as4f148838
Call-ID: [email protected]
CSeq: 1 INVITE
User-Agent: Asterisk PBX
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY
Supported: replaces
Proxy-Authenticate: Digest algorithm=MD5, realm=“asterisk”, nonce="30f9dfd6"
Content-Length: 0

Ok the problem is that I needed to put the “insecure=very” in the Outgoing / PEER Details and NOT the Incoming/User Details… Although the wording might suggest otherwise!