FreePBX | Register | Issues | Wiki | Portal | Support

SIP TO: wrong format


#1

I’m trying to setup a trunk with Iristel and I have a problem: The SIP TO: is sent in the wrong format
They receive something like this:
dialednumber%40username@sbc1.iristel.net instead of just dialednumber@sbc1.iristel.net. I have no idea where the %40username comes from.

On the same PBX, I have trunks with 2 other providers and I don’t have this issue. I’m trying to find where this format comes from but I can’t find it. Usually, I configure a trunk by using the configuration that the provider gives me, but in this case, it doesn’t work. I’m not familiar with all the SIP options in trunk configuration.

Here is he configuration I’m using (Iristel gave it to me):
type=friend
secret=(password)
realm=iristel.net
fromdomain=sbc1.iristel.net
username=(username)
host=sbc1.iristel.net
insecure=port,invite
dtmfmode=rfc2833
context=from-trunk
disallow=all
allow=ulaw
keepalive=45

Incoming calls are fine, I have the correct registration string.

Anyone knows how to send the correct TO: format ?

Thanks in advance.

Edit: I just found out this post, I will try to restart Asterisk: https://community.freepbx.org/t/cant-make-outbound-calls-via-sip-trunk/47006/5


#2

Restarting Asterisk fixed it…

Twilight zone !!!


(system) closed #3

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.