Sip station trunk configuration


Just purchased a vps server running freepbx and asterisk 1.6 from Purchased a trunk with one did from sip station

I’ve been having problems from day one. There setup configuration instruction do not work So after three days wasting time with sip station email support. Decided to use the sip station module for freepbx and use the Auto-Configure Keycode/string :

So I now have outgoing calls working. But incoming calls are still not working. I get a message this number is not in service when dialing my did.

IN the sip station module it shows the following:

Trunk Status: Primary Secondary

Asterisk Reg: Request Sent Request Sent

Contact IP: undefined undefined

Network IP undefined undefined

When I run the firewall test it display pass

Any ideas will help. Thanks again

Did you set up your inbound routes and destinations to ring groups/extensions?

I use sipstation with 2 inbound dids and both work, but I am sure if you do not set up an inbound route you can’t receive calls and you will get that error.

Within the SIPSTATION Module at the bottom or close to it you will see “DID Configuration”, Your inbound did # should be there… if it is, right next to it put a name for the did then “update did configuration”. Now goto inbound routes and set up the route for that inbound did, I route all my inbound dids into a ringgroup with time restrictions, for now I would just route that inbound did to the ext of your choice then make changes to your liking later.

Hi All

Ok. The problem was with sip station. There was a problem with there sip proxy. They did something on there side and my incoming calls started to work.

Here is a layout of events and solutions. I;m using freepbx with asterisk 1.6 from

  1. When I first created my account with sip station the admin panel in sip station was blank it was missing the sip trunk username, password and gateway info. I emailed sip station support and after some running around they resolved the problem.

  2. I had problems with outgoing calls in the beginning. So i deleted all my configuration and used the Auto-configure string for freepbx provided by sip station inside the admin panel on sip to configure my asterisk system. The string created two sip trunks. The trunks worked for going calls no problem.

  3. Once the trunks were created I had problems with incoming calls. When calling my DID the message would say this “Number is not in Use” and hang up.

I ran a sip debug commands:

rasterisk | tee ast-deb-incoming.txt
core set debug 9
sip set debug on
!netstat -aunp --> include the exclamation

Once I ran the debug I saw the following error message from my asterisk box. I also stopped my firewall using this command “service iptables stop” works with centos before running th debug to rule out any port firewall issues.

Sip station sip proxy had a problem with my sip registration request.

SIP/2.0 401 not authorized
Via: SIP/2.0/UDP;branch=z9hG4bK39599686
From: sip:[email protected];tag=as2d0d0a89
To: sip:[email protected];tag=dae6a81a6d8d2d5d596768146f317b6f.c5
Call-ID: [email protected]
Server: Phonebooth/1.0.0
Content-Length: 0

This is what my asterisk sent to sip station sip proxy for a registration request. The output above is the response from sip station.

Via: SIP/2.0/UDP;branch=z9hG4bK39599686
Max-Forwards: 70
From: sip:[email protected];tag=as2d0d0a89
To: sip:[email protected]
Call-ID: [email protected]
User-Agent: FPBX-2.7.0(
Expires: 120
Contact: sip:[email protected]
Content-Length: 0

I emailed this sip debug info to sip station email suport and they resolved the problem. There email support is not that good they take awhile to respond and sometimes you have to email them twice. Also start a new email when communicating with them do not reply. Also turn your firwall back on once complete. “service iptables start”

In any case my system is up and running. Problem resolved.

Also here is my sip station trunk configuration. This worked for me.

Trunk Description: fpbx-1234

Outbound Caller ID: Anything you want

Outgoing Settings:

Trunk Name: fpbx-1234
PEER Details

username=your username
secret=your password

Incoming Settings:
USER Context: incoming

yourusername:[email protected]

So far … for anyone else with sipstation issues …

if your pbx can resolve domain names, your firewall is not causing problems, you setup the incoming DID … then the problem is probably the provider did not setup the sip trunk correctly. Keep having this happen with sipstation and other providers - over and over again. After you strongly bother them, then the problems mysteriously get fixed without anyone admitting they changed anything.