SIP (softphone) Help needed


I have 2 SIP phones which are softphones and up until today they were working great.

Bottom issue: I changed the router (port forwarding is correct and all security settings are A-OK); however, when I rebooted my modem, I was given a new hostname.

So, from pas experience, I have learned that I neeeded to change that name in the sip_nat file. Done and done. It is correct. I also went into the GUI and changed the address under Settings>Asterisk SIP Settings (even though the sip_nat file over rules these settings).

From there, I changed the server addresses on the softphones and they will not register with the PBX.

To test locally, I entered the local ip address of the PBX into the softphones and they work just fine.

Any ideas?? :slight_smile:

Do you have access to your command prompt? If so, type this:
and then return
turn off/exit your soft phone and then launch it again. Watch the output of your screen and see if the phone is trying to register to the PBX. If you get some message that the phone is trying to register, it will tell you what is wrong. If you don’t get any message, then the phone is not getting through your firewall and you have an issue there. I suspect you don’t have your firewall set up properly. Did your modem give you a new name, or dynamic address. There is a big difference. There is a wiki post here on setting up dynamic DNS. Which distro are you using?

Well, as usual, I have found the problem. Remember when I said the port forwarding was correct? Nope, I had two digits swapped in the bind port. Admin: Feel free to delete this and my stupid head user account (but not really, thanks).

In case anyone ever sees this and thinks, what were the clues? Well, the fact that I could connect locally told me that I either had the server name (hostname), firewall issues on the router (or external firewall), OR the port forwarding is not set up right. Again, I am sorry for wasting your time. :slight_smile: