SIP over TCP?

I have been using SIP over UCP.

I just installed a Pantech modem on my router, and it or Verizon appear unable to support UCP. I tried using TCP on my wired connection, and the SIP phones are unable to register.

I unblocked the ports on my router. Is there anything I need to do on the FreePBX / Asterisk server to enable SIP traffic over TCP?

is the “transport” setting for those extension set appropriately?

Yes, the extension is set to “All-TCP Primary”. There is a note to make sure the “SIP Asterisk Settings” are set correctly but I don’t see anything on that page to set. Any ideas?

make sure


is somewhere in your your chan_sip settings

Sorry to keep bugging you.

I tried entering tcpenable = yes on the SIP settings page; I got an error message telling me to do so on the Advanced Settings page.

I went through everything on that page, and couldn’t find it. I turned on “read only” settings, and it wasn’t there either.

Is there a file I can put that in that won’t get overwritten by FreePBX?


but you should be able to add that key pair in the sip/chan sip advanced other sip settings.

When I put it in Advanced SIP Settings, I got an error message to do it on the Advanced Page. And it wasn’t there! I’ll try the conf file and see it that works!