SIP OPTIONS issue

siptrunk
configuration
Tags: #<Tag:0x00007fafbfcba090> #<Tag:0x00007fafbfcb9e88>

(Anthony Nuccio) #1

We have a FreePBX 14.0 using a Centurylink IQ SIP product for trunking. Trunk configuration has qualify=no both inbound and outbound, yet we still see SIP OPTIONS messages sent every 60 seconds (which is default by my understanding). The issue is that Centurylink will reject outbound calls (All Circuits Are Busy; 403 Forbidden in the packet) due to the frequency of these OPTIONS packets. Although it seems utterly weird to me that this would be the cause, how do I disable this for real? The only settings I can think of are in Settings -> Advanced Settings -> Device Settings, where I see a SIP qualifyfreq as 60, but if I’ve configured the trunk to be qualify=no why would this even apply or does it override somehow? And if I zero out that setting will I cause the phones issues?
Thank you all!


(Lorne Gaetz) #2

If you are using chan_sip, the qualify=no line needs to be in your peer details (and user details if used). If pjsip, set the qualify frequency to 0. The Advanced setting you noted is the default value for new extensions, and you should probably revert that change.


(Anthony Nuccio) #3

Thank you Lorne! I realize now my explanation was missing critical detail. We are using chan_sip, and thought that we had qualify=no set on both Inbound and Outbound on the trunk. What I believe happened is we set it on the Outbound and applied, but when it was set on the Inbound the settings were not applied thus causing a false positive. We applied settings and now the “ping” that Centurylink was complaining about is gone. We are over half way through the day today with no issues, which is an improvement. Why those options getting sent every minute would cause the carrier to eventually reject outbound calls is odd, but I guess it is their prerogative.


(system) closed #4

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.