Sip header too big

we tried to switch to freepbx 15 on a new vm server, we could get incoming calls but no out going our sip trunk provider said our packets were to large and the headers had unnecessary info. Could anyone point me in the right direction to get them reduced in size. Below is what they sent me.

Thanks for any help
Bert

Hello,

Here is the invite we have. As you can see there are too many fields in the SDP causing the packets to exceed 1500 bytes:

INVITE sip:[email protected] SIP/2.0

Via: SIP/2.0/UDP :5060;branch=z9hG4bK74d76333;rport

Max-Forwards: 70

From: <sip:[email protected]>;tag=as5df19f08

To: <sip:[email protected]:5060>

Contact: <sip:[email protected]:5060

Call-ID: [email protected]

CSeq: 102 INVITE

User-Agent: FPBX-AsteriskNOW-13.0.197.21(11.21.2)

Date: Tue, 07 Jan 2020 08:12:31 GMT

Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLISH, MESSAGE

Supported: replaces, timer

Content-Type: application/sdp

Content-Length: 844

v=0

o=root 1654623961 1654623961 IN IP4 s=Asterisk PBX 11.21.2 c=IN IP4

t=0 0

m=audio 13118 RTP/AVP 0 8 3 4 18 111 9 112 5 7 110 97 102 115 116 117 10 118 119 101

a=rtpmap:0 PCMU/8000

a=rtpmap:8 PCMA/8000 <------------------------- Unnecessary

a=rtpmap:3 GSM/8000 <------------------------- Unnecessary

a=rtpmap:4 G723/8000 <------------------------- Unnecessary

a=fmtp:4 annexa=no <------------------------- Unnecessary

a=rtpmap:18 G729/8000

a=fmtp:18 annexb=no

a=rtpmap:111 G726-32/8000 <------------------------- Unnecessary

a=rtpmap:9 G722/8000 <------------------------- Unnecessary

a=rtpmap:112 G726-32/8000 <------------------------- Unnecessary

a=rtpmap:5 DVI4/8000 <------------------------- Unnecessary

a=rtpmap:7 LPC/8000 <------------------------- Unnecessary

a=rtpmap:110 speex/8000 <------------------------- Unnecessary

a=rtpmap:97 iLBC/8000 <------------------------- Unnecessary

a=rtpmap:102 G7221/16000 <------------------------- Unnecessary

a=fmtp:102 bitrate=32000 <------------------------- Unnecessary

a=rtpmap:115 G7221/32000 <------------------------- Unnecessary

a=fmtp:115 bitrate=48000 <------------------------- Unnecessary

a=rtpmap:116 G719/48000 <------------------------- Unnecessary

a=fmtp:116 bitrate=64000 <------------------------- Unnecessary

a=rtpmap:117 speex/16000 <------------------------- Unnecessary

a=rtpmap:10 L16/8000 <------------------------- Unnecessary

a=rtpmap:118 L16/16000 <------------------------- Unnecessary

a=rtpmap:119 speex/32000 <------------------------- Unnecessary

a=rtpmap:101 telephone-event/8000

a=fmtp:101 0-16

a=ptime:20

a=sendrecv

Thank you,

Edwin E

Enterprise Repair

CenturyLink

Well those are codecs offerings. The only reason they are unnecessary in this case is that CenturyLink doesn’t support those codecs so there is no need for FreePBX to use them on the trunk. This can be solved by restricting the codecs used on the trunk. Since it’s looking like you are using Chan_SIP for the trunk you got into the trunk settings and add/modify these two settings:

disallow=all
allow=ulaw

That will cut back on all those other codecs being sent.

1 Like

Here’s $0.05 worth of free advice, Bert, regarding your current carrier.

The early termination fees are worth it.

5 Likes

Thanks for the info is there that big of difference in asterisk 11.21 and 16.6.2 they both have the same trunk setting and the old server works and new doesn’t.

Thanks
Bert

LOL Thanks might be going that direction.

I suspect you have very different settings for Asterisk SIP Settings between the two versions. Without setting the allow/deny lines specifically in the trunk peer details, you are using the defaults as specified in Asterisk SIP Settings. It’s been 6-7 years since I’ve seen a 2.11 system, so I don’t recall what the codec selection options looked like back then.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.