Since upgrading to FreePBX 2.9.0rc1.3 I cannot log into the GUI how to reset freepbx username/password


I am running FreePBX 2.9.0rc1.3, this was originally installed from a comlete CD distro.

Since doing an upgrade to FreePBX 2.9.0rc1.3 I can no longer log in using the freepbx account. From the console how can I go about resetting/changing or adding a new admin account.

I have researched the web and have found lots of advice for earlier versions but none (as far as I can tell) of these will apply to FreePBX 2.9.0rc1.3 due password encryption within MySQL. I am quite new to FreePBX but I do not think I am missing anything.

At the moment I cannot log in to the GUI at all. Any advice would be greatly appreciated.

My OS version is, 2.6.18-194.3.1.el5 #1 SMP Thu May 13 13:08:30 EDT 2010 x86_64 x86_64 x86_64 GNU/Linux


Me too:

Debian AMD 64 + Asterisk 1.8 + FreePBX 2.9 Beta2 + PHP 5.3

  • All goes OK at first install. I can access to GUI (without login!) and setup asterisk. I didn’t change admin password, yet.

  • After module update, SIP, Trunk, etc. setup, I can dialout

Next day I tried to access again to the GUI: no way. No user/password allowed works. I tried get access with DB user/password, after setup amportal.conf. No way.

How to reset Freepbx to gain access as admin/somepassword again?. I just can’t figure which user or password to use?, if one.

Try admin/admin.

already tried admin/admin thanks.

Just confirming other peeps suggestions…

I was running FreePBX 2.7.x on my test box and wanted to test 2.9.x. I performed an upgrade to 2.8.x and then to 2.9.x At that point the default freepbx/fpbx stopped working. I tried the admin/admin and can now access the GUI.


I’m experiencing the same issue.
Did you succeed in connecting to the GUI?


Florent THOMAS