Shiny new server tftp not serving up images


(United States) #1

Clean 02 2020 install X 2 and I can not get these boxes to serve up images to my Cisco 8961’s. The Pi does it just fine, the old " Asterisk Version: 13.22.0" does it just fine. Can manually tftp get from the server just fine?? what has changed??? with Asterisk Version: 16.6.2.

Does any one else have this issue??

did chown -R asterisk:asterisk * on the tftpboot folder not different??

Thoughts or Ideas please.


(Itzik) #2

Tftp has nothing with Asterisk. What makes you think it’s not serving?


(Lorne Gaetz) #3

Enable verbose logging for tftp and see what the logs say:
https://wiki.freepbx.org/display/PPS/Enable+TFTP+verbose+logging


(United States) #4

Perfect!, I see the problem it is working but it is so so so slow??? So just to download the List.xml file is about 50 sec… then the each thumbnail takes over a min?? So what would cause the slowdown??

errors maybe,

PS C:\Users\truey> netstat -e
Interface Statistics

                       Received            Sent

Bytes 1390663502 1307755570
Unicast packets 160740200 9441175
Non-unicast packets 4385315 20990
Discards 19768245 125
Errors 19768245 125
Unknown protocols 0


(United States) #5

Ok, new server zero errors on the nic and this the result… slow slow slow… loading the

from 15:18:58
to 15:22:09

migrating working freepbx to this new virtbox to this server to test it’s speed.


(United States) #6

ok so moved the Asterisk Version: 13.22.0 vm over to the new server and bam! 3 sec!!

Yes, PitzKeyItzik

I believe it is messed up on Asterisk Version: 16.6.2.

How do we fix it?


#7

Enable tftpd verbose in options, watcH /var/log/syslog for tftpd


(United States) #8

in /var/log/messages even with -vvv it is only a start and stop time stamp. That is where I get the 4 min plus from on Asterisk Version: 16.6.2

Don’t have a /var/log/syslog


#9
cat /etc/xinetd.d/tftp

(United States) #10

default: off

description: The tftp server serves files using the trivial file transfer \

protocol. The tftp protocol is often used to boot diskless \

workstations, download configuration files to network-aware printers, \

and to start the installation process for some operating systems.

service tftp
{
socket_type = dgram
protocol = udp
wait = yes
user = root
server = /usr/sbin/in.tftpd
server_args = -vvv -s /tftpboot
disable = no
per_source = 11
cps = 100 2
flags = IPv4
}


#11
tcpdump -vvnn port 69

(United States) #12

workin on dump now


(United States) #13


(United States) #14

so slow?? no errors either. When i was doing the firmware it was crazy long now I know why. Any thoughts??


#15

Your cisco phone will provision and pull firmware / images / ringtones over http (using port 6970). I also found my Cisco phones to be slow using TFTP (not as slow as you are seeing, but still slow) so I added a vhost for port 6970, with appropriate restrictions, and pointed it to the tftp location.

You don’t need to change your dhcp server. The phone simply tries the TFTP IP address using http on port 6970 before it gives up and uses regular TFTP instead.

Edit: note this is only true for the Java phones (7961 and newer, so if someone comes along with a 7960 you are stuck with tftp). Here are a couple references:

http://usecallmanager.nz/apache-conf.html


(United States) #16

Yes, I look at the sccp conversion and that looks great just dont have the time. Will pursue it sometime as everyone wants BLF.

Is sccp required to do the Vhost?


#17

No you can use http(6970) whether you run SIP or SCCP.


(United States) #18

Ok they killed my tftp issue??

https://issues.freepbx.org/browse/FREEPBX-21242?focusedCommentId=180358&page=com.atlassian.jira.plugin.system.issuetabpanels%3Acomment-tabpanel#comment-180358

So to this vhost thing

What and were do I add this to the server?(no clue)

Found this information great but that would make me loose the standard tftp port?

What and were do I add this to the phone? (thinking sepmac.xml) (or do the java based phones just search there?)


#19

Yeah you were told here in this thread that TFTP has nothing to do with FreePBX; not sure why you are surprised they closed your FreePBX bug report.

The vhost gets set up in Apache configs, a straightforward task you can search on Google. Apache and TFTP are separate subsystems so you can run them at the same time; you won’t lose your TFTP access.

As I already stated about your phone/DHCP setup…


(United States) #20

Ok, put vhost in conf.d and restart. Can browse to it on port 6970 but the phone is still as slow as can be. It is a 8961 and 8941, what do I do to have the phone use this port?