Setup FreePBX from scratch with Tata PRI Card

freepbx
Tags: #<Tag:0x00007f702de09a08>

(India) #1

I Wanted to setup a freepbx for my office, i am totally new to freepbx. somehow i managed to see my Sangoma A101 PRI card in FreePBX.Alarms are showing ok & green indicator on PRI card.
I checked that link is working fine at the time of setup.
I tried to setup incoming & outgoing routes but not successful.
I have only 15 phones in network & need very basic setup like.:

  1. All incoming calls must be getting delivered to reception extension & receptionist can forward calls to specific intercom / mobile numbers.
  2. Everyone can make outgoing calls including international calls with pin authentication setup.
    It will be very helpful if someone can help me to configure.

#2

Please share what you have done so far.


(India) #3

I Just have added the drivers of Sangoma A101 PRI Card & Tried to add inbound & outbound routes with below settings.
Inbound:
image

when i try to call from extension, recorded message received that all circuits are busy now.


(India) #4

Outbound Routes


#5

outbound routes need at least one trunk


#6

to what context is your inbound trunk directed?


(India) #7

Can you please guide me, what to add in Outbound CallerID column?


(India) #8

Actually, i am totally new to IPBX / FreePBX system, how to add inbound trunk cause i am seeing only Outbound CallerID trunk & not inbound caller trunk.


#9

there is a link to the wiki at the top of this page


(India) #10

I have seen lot of info on SIP line configuration but not on PRI setup.


#11

Start here

https://wiki.freepbx.org/display/PC/Telephony+Cards+for+Asterisk


#12

First of all, you should get the specific PRI details from Tata, because each provider uses specific parameters that you must know in order to correctly configure your Sangoma card.


(India) #13

All PRI settings are correct as per Tata’s settings.


#14

So have you configured the span with those settings?


(India) #15

Yes, Right & in Asterisk Info, Dadhi PRI SPAN is showing up.
PRI span 1/0: Up, Active
while making outgoing calls it showing bad gateway & incoming calls are showing as invalid number.


#16

Have you consulted with your provider? Regarding outgoing calls, they probably expect your caller ID formated in a specific way.
I guess you already fixed it, but according to your picture, your outbound route has no trunk assigned, so that is why it wouldn’t work if you didn’t fix it.
Did this setup work before or are you using this PRI for the first time?


(India) #17

Hi, Thank you so much for your support.
I was totally missed that point of caller id format.
After adding all possible CID Format in incoming routes, incoming calls are working.
Tomorrow, i will try to make outgoing calls also.
Hopefully it will work as expected. Thank you again.


(system) closed #18

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.