Setting up OBI110 for FXO Gateway


(James) #1

Good Morning all, I have been looking at some videos and seen one post on hear regarding this as well. Issue is OBi110 dose not seem to be registering to freepbx and get the following error:
"Register Failed: 403 Forbidden (server=192.168.0.10:5060;retry in 26s)
Now as per post I changed to port 5160 on Obi110 and still same issue, I have four cisco 79XX phones running on port 5060 and can call each extension no problems. Can the ObI still use the same port? or is that why post says to change to port 5160?

Setup is as follows
Obi110:

ITSP A
ProxyServer 192.168.0.40
ProxyServerPort 5060
RegistrarServer 192.168.0.40
Registrar ServerPort 5060
X_SpoofCallerID checked
X_AccessList 192.168.0.40

Voice Services

SP1:
Enable checked
X_InboundCallRoute LI

Sip Credentials:
AuthUserName OBiTRUNK1
AuthPassword 1bc23456 <<<no matter what i set to and save it always shows '****’ 8 **
** asterisks even if password is 12 characters long, is this normal?

Physical Interfaces
Line Port:
InboundCallRoute SP1(XXXXXXXXXX)

FreePbx
Trunk Name OBiTRUNK1
Outbound CallerID XXXXXXXXXX
Dialed Number Maniputlation Rules
Match pattern X
Outgoing
Trunk Name OBiTRUNK1
PeerDetails
username=OBiTRUNK1
secret=1bc23456
host=192.168.0.10
type=freind
context=from-trunk
qualify=yes
dtmfmode=rfc2833
canreinvite=no
disallow=all
allow=ulaw

Now I have tried switching ports to 5160 as well but still same results, I am also not sure about the OBi110 password field, is it normal if you put in a password longer than 8 characters and then when saved and you go back into that setting it always shows 8 ‘********’ ?

Thank You in advance for your help, comments, or suggestions

James


#2

For your trunk settings, PEER Details:

username=OBiTRUNK1
secret=1bc23456
host=dynamic
type=friend
context=from-trunk
qualify=yes
dtmfmode=rfc2833
canreinvite=no
disallow=all
allow=ulaw

Note spelling of “friend”.

Go to Asterisk SIP Settings, chan_sip tab, and note the value of Bind Port. This defaults to 5160 but you may have changed it.

Then, in the OBi, set both ProxyServerPort and RegistrarServerPort to whatever you saw for Bind Port.

Reboot OBi and test.


(James) #3

Great, yes I had friend spelt correctly in the peers just mistype it in my example.
I switched bind port from 5060 to 5160 and now it seems to be Registerd, Thank YOU.
Now though when i dial from one extension to another nothing works on my internal phones so I guess I will try setting the ports in my SEPxxxxx.cnf.xml files to port 5160?


(James) #4

Great,
Thank You Stewart, I changed my phone ports to 5160 as well and they are talking to each other again.
I am also receiving inbound calls to my phone/s but I can’t seem to dial outbound from my phone/s.
Just need to check into that configuration, and I did and it seems to be working just a long delay before it actually dials outbound calls.

Thanks Again Stewart

James


#5

Possible reasons for the long delay:

The phone’s dial plan may be incorrect. Use the Asterisk console to see when the phone sends the call to Asterisk. Possibly, pressing #, Dial or Send after entering the last digit will cause the phone to send the call immediately.

There could a timeout e.g. doing a STUN lookup. In Asterisk SIP Settings, STUN Server Address should normally be blank (unless you have another application, not mentioned, that requires it).

The OBi could be delaying the call; check Line Port parameters (Dial Delay, Dial Digit timing, etc.)

The device or service that the OBi is connected to could be delaying (waiting to see whether more digits are coming). What is the OBi connected to (copper pair from central office, cable MTA, fiber ONT, ISP-supplied adapter, etc.)? What country are you in? What format are you dialing?


(James) #6

Yes, I played with the delay adj. in the OBI110 and it seems to dial out a lot quicker now. I am using it on a majicjack for now as it is one of the lines I have setup for calling the US.

DialDigitOnTime: 50

DialDigitOffTime: 50

James


(James) #7

Quetion for you Stewart1,
I have everything working with this setup, I can dial out to the MJ and a 10 digit rings through locally for me but if I put a 1 into the mix I get a message back that I need to dial a 1 or area code and then MJ hangs up. I checked outgoing manipulation rules on OBI110 trunk and set up for long distance and 11 digit dialing but still not working. Is there and adj. in the OBI110 that needs to be done for long distance?

Thank You

James


#8

I’m not sure what you are asking. Do you want to dial e.g. 1 800 437 7950 (a caller ID test number) and send 800 437 7950 to magicJack? If that’s correct, just add a Dial Pattern to your Outbound Route with:
prepend: (leave blank)
prefix: 1
match pattern: NXXNXXXXXX

leaving existing Dial Patterns as they are.

If you still have trouble, make a failing test call and look at the Asterisk log. You should see a line with
Executing [18004377950@from-internal:1]
if that’s not there or the number is wrong, check the phone’s dial plan.
And there should be a line with
Called SIP/OBiTRUNK1/8004377950
if that’s not there or the number is wrong, check your route and trunk dial patterns.

If both of the above are correct, check the digit map for the Line port in the OBi.


(system) closed #9

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.