Setting up Exim for sending email (VM & Fax delivery)

I’ve been trying to get Exim4 to send email but I’m getting absolutely nothing.

I thought that maybe I had entered some setting that I shouldn’t have (entered something different when I was supposed to accept the default for example). So I had FreePBX do a complete backup.

Then I basically started from scratch: reloaded the original image on my SD card and then booted up and went through the initial setup again. The second time around, I was very careful to follow the instructions.

But when I run that command to send a test email, NOTHING arrives in my inbox.

The SMTP server is the same as the server that’s receiving the message (an email server on my hosted web account).

But I’m at a complete loss as to how I can go about troubleshooting this.

Here’s the config file that was generated by the configuration util.

dc_local_interfaces=‘ ; ::1’

What is exim? I had to configured Postfix so my FreePBX is able to send voicemail and fax messages.

"What’s Exim?"
It’s a very popular mail transfer agent.

I downloaded and installed the rasberry-asterisk image which has FreePBX and exim already installed by default.

Thanks for pointing that out. I need to read on that and see if there is any reason for me to use that instead of Postfix which does what I want pretty reliably for a while now.

looks like exim is installed to replace sendmail, did you try to send a test email using “mail -s” command?

After a lot of reading, I did find that suggestion. But I still received nothing in my inbox. I found something documenting SSMTP (another MTA) and tried that. Still nothing. So I configured it to send via my gmail account. That worked.

Also check the mail logs in /var/log it would say what fails.

I had no problems with gmail and accounts. Both are secured SMTPs. Check you account with something like thunderbird or MS Outlook, see if you can get it working in there. If gmail works, then anyting else should work also.