Session Progress handshake packet truncates with a [!sip]


(Beaglemaster) #1

I am new to this forum and voip so please be patient with me.
I just added a second DID to a provider and it seems to work except the caller does not hear a ring back and will terminate after a given amount of time (18 seconds). I have been working with the provider and they insist that it is my problem. I decided to get a tcpdump of the handshaking to make sure everything is good. I compared the handshaking of the second DID with that of the first DID (which works perfectly) and first I noticed that the INVITE packets from the provider are pretty different which tells me that the configuration of the two DIDs are different. I then noticed in the Session Progress handshake gets truncated because the limit size of the packet is reached.
I tried to include the truncated packet capture but I couldn’t post it.

Does anyone know why the Session Progress handshake packet would be larger than the max packet size? Is there anyway that I can control it?

I am curretnly usingFPBX-13.0.192.19 (Asterisk PBX 13.22.0)

Thanks for any help


(David55) #2

You would need to get the protocol debugging logs from Asterisk, not from wireshark, although you should consider the possibility that wireshark is truncating the captured packet, rather than the system doing so.


#3

Try allowing only the ulaw or alaw codec on the trunk (whichever is appropriate for your country).

If no luck, paste the SIP trace at pastebin.freepbx.org and post the link here.


(Beaglemaster) #4

Thanks for the replies and help. After many hours I was able to figure out the problem. The provider configured the first DID via SIP but configured the second DID for pjSip. They did not alert me to this but through trial and error and realizing there were different configurations that I was seeing in wireshark, I tried pjsip and everything work.

Again, Thanks for the help.


(system) closed #5

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.