Server tries to communication with non-existant extension

I’ve just got to be missing something here. After a long-overdue upgrade from Ast 1.2 and FreePBX 2.5, I’ve rebuilt my server with Ast 1.6.2 and FreePBX 2.8.

Everything was working fine. Then, I started farting around with the VLAN settings on my Cisco 1252 AP and my Cisco 7970 phone stopped working. After that, I set the AP back to the original settings. The phone is on the same subnet as the Ast server, and the 1252 shouldn’t have anything to do with it, but a sniff shows that they exchange some “CDP” (Cisco Discovery Protocol) messages.

Anyhow, turning on debugging of SIP inside Ast shows that the server keeps trying to communicate with the two extensions on my phone. The trouble is that it’s not using their correct extension numbers. One extension is 210 and the other is 211. However, Ast keeps trying to talk to them as 3000 and 3073 like so:

Retransmitting #3 (no NAT) to 10.0.0.64:5060:
OPTIONS sip:[email protected]:5060;transport=udp SIP/2.0
Via: SIP/2.0/UDP 10.0.0.74:5060;branch=z9hG4bK389b9f9d;rport
Max-Forwards: 70
From: “Unknown” sip:[email protected];tag=as0be8f65b
To: sip:[email protected]:5060;transport=udp
Contact: sip:[email protected]
Call-ID: [email protected]
CSeq: 102 OPTIONS
User-Agent: Asterisk PBX 1.6.2.13
Date: Mon, 04 Oct 2010 18:46:05 GMT
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO
Supported: replaces, timer
Content-Length: 0


Retransmitting #4 (no NAT) to 10.0.0.64:5060:
OPTIONS sip:[email protected]:5060;transport=udp SIP/2.0
Via: SIP/2.0/UDP 10.0.0.74:5060;branch=z9hG4bK53be7f90;rport
Max-Forwards: 70
From: “Unknown” sip:[email protected];tag=as74efb455
To: sip:[email protected]:5060;transport=udp
Contact: sip:[email protected]
Call-ID: [email protected]
CSeq: 102 OPTIONS
User-Agent: Asterisk PBX 1.6.2.13
Date: Mon, 04 Oct 2010 18:46:05 GMT
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO
Supported: replaces, timer
Content-Length: 0

It just does this over and over again. The phone boots up and gets its (correctly formatted) config file from the TFTP server, and then just hangs at “Configuring IP”.

A real head-scratcher is that the config files don’t have these extensions anywhere to be found, for example:
[[email protected] asterisk]# grep 3073 *conf
[[email protected] asterisk]#

A grep of one of the real extensions shows tons:
[[email protected] asterisk]# grep 210 *conf
extensions_additional.conf:exten => 600,n,Macro(record-enable,210-220-202-240,${RecordMethod})
extensions_additional.conf:exten => 600,n(DIALGRP),Macro(dial,20,m(default)t,210-220-202-240)
extensions_additional.conf:exten => 2,n,Goto(ext-local,vmu210,1)
extensions_additional.conf:exten => t,n,Goto(ext-local,vmu210,1)
extensions_additional.conf:exten => 2,n,Goto(ext-local,vmu210,1)
extensions_additional.conf:exten => t,n,Goto(ext-local,vmu210,1)
extensions_additional.conf:exten => 210,1,Set(RingGroupMethod=none)
extensions_additional.conf:exten => 210,n,Macro(record-enable,210,IN)
extensions_additional.conf:exten => 210,n,Macro(dial-one,${DIAL_OPTIONS},210)
extensions_additional.conf:exten => 210,n,Hangup
extensions_additional.conf:exten => **210,1,Pickup(210&[email protected]&[email protected]&[email protected]&[email protected]&[email protected]&[email protected]&[email protected]&[email protected]&[email protected]&[email protected]&[email protected]&[email protected])
extensions_additional.conf:exten => **210,n,Hangup
extensions_additional.conf:exten => 210,1,Macro(exten-vm,210,210)
extensions_additional.conf:exten => 210,n,Goto(vmret,1)
extensions_additional.conf:exten => 210,hint,SIP/210
extensions_additional.conf:exten => ${VM_PREFIX}210,1,Macro(vm,210,DIRECTDIAL,${IVR_RETVM})
extensions_additional.conf:exten => ${VM_PREFIX}210,n,Goto(vmret,1)
extensions_additional.conf:exten => vmb210,1,Macro(vm,210,BUSY,${IVR_RETVM})
extensions_additional.conf:exten => vmb210,n,Goto(vmret,1)
extensions_additional.conf:exten => vmu210,1,Macro(vm,210,NOANSWER,${IVR_RETVM})
extensions_additional.conf:exten => vmu210,n,Goto(vmret,1)
extensions_additional.conf:exten => vms210,1,Macro(vm,210,NOMESSAGE,${IVR_RETVM})
extensions_additional.conf:exten => vms210,n,Goto(vmret,1)
extensions_additional.conf:exten => office,1,Goto(from-internal,210,1)
extensions_additional.conf:exten => 210,1,ExecIf($["${BLKVM_OVERRIDE}" != “”]?Noop(Deleting: ${BLKVM_OVERRIDE}: ${DB_DELETE(${BLKVM_OVERRIDE})}))
extensions_additional.conf:exten => 210,n,Set(__NODEST=)
extensions_additional.conf:exten => 210,n,Goto(from-did-direct,210,1)
extensions_additional.conf:exten => ${VM_PREFIX}210,1,ExecIf($["${BLKVM_OVERRIDE}" != “”]?Noop(Deleting: ${BLKVM_OVERRIDE}: ${DB_DELETE(${BLKVM_OVERRIDE})}))
extensions_additional.conf:exten => ${VM_PREFIX}210,n,Set(__NODEST=)
extensions_additional.conf:exten => ${VM_PREFIX}210,n,Macro(vm,210,DIRECTDIAL,${IVR_RETVM})
extensions_additional.conf:exten => ${VM_PREFIX}210,n,GotoIf($["${IVR_RETVM}" = “RETURN” & “${IVR_CONTEXT}” != “”]?ext-local,vmret,playret)
sip_additional.conf:[email protected]
sip_additional.conf:[210]
sip_additional.conf:dial=SIP/210
sip_additional.conf:[email protected]
sip_additional.conf:callerid=device <210>
sip_additional.conf:[email protected]
voicemail.conf:210 => 9999,Office,[email protected],attach=yes|saycid=yes|envelope=yes|delete=no
[[email protected] asterisk]#

Anyone here have any idea why it would be trying to talk to extensions on my phone that don’t seem to exist?

I realize that this may be an Ast problem and not a FreePBX problem. Since all of my config is done with FreePBX, though, I’m hoping someone here has some insight.

Thanks,
Jamie

phoneserver*CLI> sip show peers Name/username Host Dyn Nat ACL Port Status 202/202 10.0.0.67 D N A 5060 OK (167 ms) 210/3073 (Unspecified) D A 0 UNKNOWN 211/3000 (Unspecified) D A 0 UNKNOWN 220/220 10.0.0.68 D N A 5060 OK (5 ms) 4 sip peers [Monitored: 2 online, 2 offline Unmonitored: 0 online, 0 offline]
That only deepens the mystery, though. Nowhere in any .conf file does 3073 appear.

What does sip show peers show ?