Sending *

This is really an asterisk feature conflict, but thought I would throw it out here.

I have a user that has to file a monthly report via telephone to a State agency. The date is entered using an * as a separator. That is, to enter January 31, 2012 she has to punch in “01312012” on the touch tone pad. Problem is that the * is being intercepted by asterisk and interperated as the beginning of a feature code. Anybode have any ideas on a workaround to allow the * to be used in overdial?


Are you sure it’s not an incorrect digit map on the phone? What kind of phone does the user have?

Try completing the task Using a softphone like X-Lite… My guess is you will find it works.

Pretty sure it’s not the digit map because in the example given, the system sees the *2 portion of the entry as a transfer request.

I think your only choice will be to disable the feature code.

Yes except their code changes every month and all feature codes start with a *. It bad design of the service they are using to use a * since most PBX’s use * internally for feature codes.

Agree completely, Tony, I suspect the reporting system is an old legacy system that didn’t take the service codes into account when it was designed. Surely, this is not PERS first encounter with this. Guess I’ll have to call tomorrow to determine if there is an alternate reporting procedure.