Send calls directly to mobile phone

freepbx
Tags: #<Tag:0x00007fafbf77b138>

(Dimitris) #1

Hi guys, please en light81533520_2526719400711215_901687371152490496_n

me. I want a certain extension from our Asterisk PBX 1.8.20 to ring straight to a mobile number. How do i do that ? I know its old and i know how to set it up on a newer version. But how do i do it on this one? Please help. Thanks


(Lorne Gaetz) #2

I don’t have an answer for you, but in case you’re not aware, this system has been end of life for years. You need a plan in place to get on a supported system. The good news is that a backup taken from this system can probably be restored on a new 15 install, tho you will want to test that well before committing.


#3

If regular Call Forwarding Unconditional works on your system, that would be easiest.

If not, does it have Follow Me working?


(Dimitris) #4

These are the follow me settings available on the extension 609 that i want to set to ring to mobile number 698XXXXXXX. Can you please provide instructions on how to do so ? everything i googled didnt work or maybe i am doing it wrong… Thanks


(Moussa) #5

Add “#” at the end of 698XXXXXXX

You can include an extension on a remote system, or an external number by suffixing a number with a pound (#). ex: 2448089# would dial 2448089 on the appropriate trunk (see Outbound Routing).

FYI,
Same thing apply to Ring Group


(Dimitris) #6

So in the “Follow me list” field i set the mobile number and extension such as in the screenshot ?


(Moussa) #7

Yes :+1:


(Dimitris) #8

Did it as sawn but i am calling the number now and it gives a busy tone. It doesnt ring in my mobile.


(Moussa) #9

Is is the right phone number format for your system?
What happens when you dial 698XXXXXXX from an extension?


(Dimitris) #10

yes it is. its the actual mobile numbers for greece. 10 digits


(Moussa) #11

What happens when you dial 698XXXXXXX directly from an extension? do you get a busy tone?


(Itzik) #12

Can you provide a call log?


(Itzik) #14

You just posted a random piece of the logs. Nothing here seems to be related to the actual call.

https://wiki.freepbx.org/display/SUP/Providing+Great+Debug#ProvidingGreatDebug-AsteriskLogs-PartII


(Dimitris) #15

2122223609 is my extension /incoming trunk and the mobile i want to send it is the 6980578708


(Dimitris) #16

any thoughts ???


(Dimitris) #17

no it rings its my phone.


(Dimitris) #18

any thoughts man ?


(Moussa) #19

Log to to SSH as a root and type this grep 123456 /var/log/asterisk/full* replace 123456 with the uniquieid from the system column for the call in question


(Dave Burgess) #20

OK - the problem you are having is that we didn’t do this “the easy way” back in 2009. There were several things that got in your way. Here’s what I had to do back then:

  1. Set up a different trunk to send the call to. The Chan-SIP code from back then didn’t handle "ricochet’ routes very easily. Also, you will need to set up with a provider that allows for “foreign” caller IDs to be passed so that CID on the cell call is correct.
  2. Set up a Misc Destination (IIRC) that dials your cell phone number.
  3. Set up an outbound route that points to the new trunk you created and has the cell phone number as produced by your system as one of the “match” criteria for the call. This will make it so this trunk is only used for these outbound calls to this cell phone.
  4. Set up a “setCallerid()” destination that sets the outbound Caller ID. Point this calls destination to a Misc Destination(I think) that allows for a call to your cell phone.

The “new” way is just for forward the call, but in a system that old, you have to jump through these hoops to get it to work right.


(Dimitris) #21

Guys the issue was solved by filling in the caller id of the line since the provider would not allow calls through without it.

After doing so the issue was solved by adding the mobile number in extension’s follow me settings followed by #