Select/search for name from main Directory bug

Husband and wife with same last name. He’s Tom, she’s Wendy. Directory search uses first three letters of first or last name. Incoming caller searches for Wen and the call is placed to Wendy. Search on the last name, the attendant says there are two names that match. Hit # sign to choose, then the Attendant says “For press 1. For T O M, press 2.” If you press 1, the call goes to Wendy.

The system is not “reading” Wendy’s first name. I looked at the voicemail.conf file and the entries for Tom and Wendy are identical. I’ve rebooted the server. I’ve deleted and recreated Wendy’s Extension. No luck.


I solved this by using Edit Directory in the FreePBX GUI. All the directory entries had the default “Voicemail Greeting” selected under the Name Announcement field. I changed Wendy’s to “Spell Name”. That fixed it. Now her name is spelled out after Tom’s when an incoming caller searches the directory using the last name. Not sure which version of Asterisk and FreePBX I’m on… probably not the latest. If it ain’t broke…