SDA2 keeps going into read only mode requiring reboot

FreePBX 64 bit. Kingston 120gb ssd. Supermicro motherboard.

I ran every test I could imagine from the command shell, no errors found on the hard drive or file system, yet EXT4 on SDA2 (the good stuff) will randomly throw itself into read-only mode and requires a reboot to put back read/write.

This is bad. Help.

Some other guys said this. Click that link and read through it - it talks specifically about EXT3 file systems on SDD drives under Linux and VMware.

I ran the latest yum updates and it updated to 2.6.32

We’ll see what happens. Only happens on my servers with Kingston drives. My newer ones have intel SSD’s. Might have to swap it out if it happens again

From reading the article - I doubt it’s your drives. It sounds like the drive interface is getting overloaded, and there’s little you can do to alleviate that. You’re already using SDD drives.

Without reading the above link this happens when linux thinks the drive is toast. In theory you get this and you should pull all your data and replace the drive. If this happens across a brand that means their drive firmware is responding inappropriately and making the kernel think it is bad. If that is what the above link says ignore me :wink:

1 Like

This has happened now on two kingston SSD servers. The one in question right now is not even in production yet it’s been sitting in the rack for 3 months untouched.