Scripted upgrade to CentOS 5.8 doesn't work

I am attempting to get my FreePBX updated using the scripts located at as a starting point. I get to the script that is supposed to upgrade from CentOS 5.7 to CentOS 5.8 and the script works fine without any errors. It finishes and asks me for a reboot so I do. The system reboots fine and checking the FreePBX sysadmin module shows the correct version (ex.1.814.210.58-1). But when checking Webmin or using the cat /etc/*release command, the system still shows as being on CentOS 5.7. I tried running the scrip again with the same result. My FreePBX is still working fine as well. I don’t know what I am missing. Any help would be appreciated.


Was the system originally a distro? What version distro did you start with? Did you run all scripts n order?

Yes, the system was originally a distro. I started with the downloadable ISO from this site. I can remember the exact version I started with cause it was a while ago but I believe it was I did do all the scripts in order and tried the one that upgrades the OS twice with no difference. I also tried the next script after the OS upgrade and it also did not upgrade the OS. I stopped going through the scripts at that point out of fear I might break something and might not be able to fix it with my very limited Linux experience. Also, is there any new scripts to upgrade to the newest distro or can that only be done with a clean install.

Thanks for the help.

Ignore what you see in the redhat release file. We never updated that. Just run the scripts and it wil update everything

So even though web min is still saying CentOS 5.7 the OS is now 5.8?

Also do a uname -r

I will look at that and post back with the results. So that leads to the next part of the question… Is there an upgrade path from the last CentOS 5.8 distro to the newest stable release with CentOS 6.2?

Thanks for all the help so far.

Yes it should be. If you ran those upgrade scripts it will take it to Centos 5.8 packages and kernel

Look at what version is in /etc/asterisk/freepbxdistro-version

Probably not unless you feel adventuresome.



. . .Similar to the practice of the upstream vendor, there is no supported path to ‘upgrade’ an installation of a prior major CentOS release (presently CentOS 5 or CentOS 4) to a new major release. This is not a CentOS imposed limitation, but rather reflects the upstream’s approach on this matter. People who feel adventuresome and want to experiment are reminded to take and test backups first. As a note to people who attempt the upgrade in spite of this warning, such as by the unsupported upgradeany option from the media install command line, please note that you will need to manually retrieve the current centos-release package, manually do a rpm -e --nodeps removal of the prior centos-release package, and then manually install the CentOS 6 centos-release package, before yum can have any chance of working properly. . . .

(It is my opinion that if you use Debian not Centos (not so many FreePBX distros do) keeping current with your OS through major releases is not a problem as there is no “upstream vendor” involved. Compare and contrast with:-

It is unambiguous, open source and not dependent on anything but itself. Centos not so much it relies on a commercial product (Redhat) and so you will always be a couple of steps behind when it comes to hardware and kernel support for new technology.

this post is in “Installation” not “Distro Discussion & Help” which is Schmooze specific and probably where this thread really belongs, so no flames please :wink: , JM2CW and IWFM )