Sccp module for freepbx 14 HELP ME!

I need Help installing a SCCP module for freepbx 14 i have about 40 Cisco 7961g phones and have ran into countless issues trying to install sip firmware on the phones and would like to just go ahead and install sccp on to freepbx

Maybe this can be helpful, take a look at:

I wrote the installation instructions for FreePBX for this. It works perfectly for me using a ‘flat’ sccp.conf file or using the “sccp.conf+sccp_lines+sccp_devices” three-file method I describe in the Installation Instructions.

I literally installed a new system with this two weeks ago.

1 Like

Thanks for the fast reply guys Cynjut do you have a link a few of the Documents i have got into have not worked for me. It’s most likely a PEBKAP error but I catch on easy

well pretty much and install guide I can’t really find on that makes sense to me. or that actually work

so i have tried using this Documentation and i keep getting stuck at trying to copy the chan-sccp file to the pbx. i have never accomplished the transfer

How are you trying to copy the file?
Are you getting any error message?

I am using ssh to run the commands I Have no idea how to copy the file I think that is why I’m stuck.

I am running PBX inside of hyper-v I’m unsure if that makes a difference

Installing Chan-SCCP on FreePBX derivative systems is quite simple. The general instructions are:

  1. download the source for chan-sccp-b that corresponds to your version of Asterisk, un-tar it,
  2. ‘cd’ into the source directory
  3. execute:
./configure --enable-conference --enable-advanced-functions --enable-distributed-devicestate # check './configure --help' for more options
make -j2
make install

This is where im stuck if that helps?

These are the instructions I updates 3 weeks ago.

Start at the top. Work your way down. These steps are required.

yum update
yum upgrade
yum install git asterisk-devel
cd /usr/src
git clone https://github.com/chan-sccp/chan-sccp chan-sccp
cd chan-sccp
./configure --enable-conference --enable-advanced-functions --enable-distributed-devicestate
make -j2
make install

At this point, you should have the chan-sccp.so in the driver directory.

Log into the FreePBX GUI. go to “Admin”, the “Asterisk Modules” Unload the chan_skinny module and load the chan_sccp module.

Restart Asterisk (go back to the console) using “fwconsole restart”.

When Asterisk restarts, run “asterisk -vr”. At the prompt, type “sccp ?” and see what options come up.

1 Like

You are trying to compile the driver with those commands, not copying an already compiled binary. Does your server have all the prerequisites needed to be able to compile software from source? If not, you should either make sure to have all the prerequisites, or use one of the precompiled binaries, if one is available for your particular combination of OS name and version and Asterisk version.

I’ve never had good luck with that, so I don’t even bother anymore, but hey, what do I know. :slight_smile:

@cynjut
./configure --enable-conference --enable-advanced-functions --enable-distributed-devicestate
make -j2
make install

the first command has an error I’m unable to get passed I can get the error in just a sec

@cynjut
[[email protected] chan-sccp]# ./configure --enable-conference --enable-advanced-functions --enable-distributed-devicestate
checking for gcc… /usr/bin/gcc44
checking whether the C compiler works… no
configure: error: in /usr/src/chan-sccp': configure: error: C compiler cannot create executables Seeconfig.log’ for more details
[[email protected] chan-sccp]#

sorry for all the random reply’s kind of everywhere… so I’ve figured out i was in the wrong directory and now im getting a permission denied error is there some kind of sudo command i’m missing?

i have got the module installed this is where i dont understand shouldn’t i be able to just set up a chan-sccp extension in the gui

No.

You can add the SCCP Manager from GitHub, or you can edit the sccp.conf file from the source directory. There is no native SCCP support in FreePBX. Part of that is beyond our pay grade, but part of it is that Chan-SCCP-B is written for both Asterisk and FreeSwitch.

Man im probably in for a few long nights of copy and paste i cannot find a config file for my phone model and i cant write on myself in not smart enough for that thanks for the help i got installing sccp but configuring the hones is another story

There are a lot of working examples on this forum and on the internet in general. You just need to google it.

All you really need is the MAC addresses for your phones and to set up the line definitions in the GUI.

The sccp.conf file allows for templating, so you set up the phone config once and then use the template for all the phones. All you need to add is the lines. With 50 phones, it should take 20 minutes.