SCCP Manager manager installation errors

Hi all, so my goal is to setup the cisco cp8841 phones on the FreePBX sccp, I have been reading fragments of instructions (I haven’t find the definitive guide) in different posts of this forum, and googling in general, so this is what I understand and PLEASE correct me where I am wrong with this:

I am using the Asterisk 20.5.2 from the distro SNG7-PBX16-64bit-2306.iso

I first need to download and install the module SCCP Manager, correct?
Then I need to download and compile Chan-SCCP-B or chan-sccp (what is the difference between these last two?)
Then I need to make this changes to /etc/asterisk/modules.conf
noload =
load =

I was able to compile chan-sccp and it generated the on my filesystem, so is that the process in general speaking or I don’t really need to first install the “SCCP Manager” module? I read in some forums that says in very generic way “replace SCCP Manager by chap sccp” but I have no clue how is that done, I added load = but this was not present on my modules.conf : noload =

Also, I downloaded the SCCP Manager from: GitHub - chan-sccp/sccp_manager: SCCP Manager
Followed the installation instructions but the module manager gives me these errors that I cant figure out what they mean or how to solve them:

Whoops \ Exception \ ErrorException (E_WARNING)
Creating default object from empty value

7 Whoops\Exception\ErrorException
6 Whoops\Run handleError
5 FreePBX\modules\Sccp_manager\srvinterface __construct
4 include_once
3 module_functions _doinclude
2 module_functions _runscripts
1 module_functions install
0 include

I would really appreciate your inputs, I know this topic has been discussed in different posts, but I haven’t been able to solve my problem, and I haven’t been able to fully understand the process of get this done yet.

Thanks, very appreciated.

Hello friend!
Actuallu you first need to install chan_sccp and then install sccp_manager, if you try to install sccp_manager before chan_sccp it may give an error due to failure to recognize the module.

So, the procedure to install chan_sccp is this (skip to sccp_manager if you already have it installed):

  • First, let’s update the server and install some configuration files
yum update
yum upgrade
yum install git asterisk-devel autoconf automake gcc
  • To provision the phones with their config file, we need to have a tftp server.
    To make sure a tftp-server is installed we run:
yum install tftp tftp-server* xinetd*

After that we have to update/edit the /etc/xinetd.d/tftp file to enable the tftp server.
You should only have to change the disable line to “no”. It should look something like:

service tftp
    id              = tftp
    socket_type     = dgram
    protocol        = udp
    user            = root
    wait            = no
    disable         = no
    server          = /usr/sbin/in.tftpd
    server_args     = /tftpboot
    FLAGS           = IPv6 IPv4

Then restart xinetd

systemctl restart xinetd

After updating the packages and installing the TFTP server, let’s move on to downloading chan_sccp:

cd /usr/src
git clone chan-sccp
cd chan-sccp

And now lets install it:

./configure --enable-conference --enable-video     # check './configure --help' for more options
make -j2
make install

After that, we activate it on FreePBX GUI:
Via the FreePBX GUI navigate to Admin->Asterisk Modules, under

  • under ‘Excluded Modules’ add
  • under ‘Manually Loaded Modules’ add

After that, save it, apply it, and i like to do a fwconsole chown and a fwconsole restart to ensure everything is installed and running correctly.

Now that everything is ok with Chan_SCCP, let’s install SCCP Manager!

PS: in my experience, the stable version presented some errors, mainly when configuring the devices. The DEVELOP version works perfectly, I have been using it for more than six months (in test and production environments) and it has never presented any bugs, unlike the stable version, so I recommend using it. But you can test both on your own and see which is best for your scenario.

  • Log in to FreePBX
  • Go to Admin → Module Admin
  • Click Upload Modules.
  • Enter one of the following urls: (Stable Version) (Develop Version, works better for me)

  • Click Download From Web
  • Do a fwconsole chown from CLI to prevent permission errors after downloading
  • Click Manage Local Modules
  • Find and click SCCP Manager. Check Install. Click Process button.
  • Confirm installation.
  • Close Status window.
  • Apply Config to FreePBX.

After that, you can use SCCP Manager normally to configure and provision your phones, I followed this step by step on more than 5 servers with approximately 120 Cisco 7965 (they are popular in Brazil haha) and it works very well, if you have any questions you can tag me.

Source of information used:


PS: Do you already have a DHCP server?
You can also do this in FreePBX, but I prefer to define DHCP Options 66 and 150 in the network gateway that the phones are connected to so they can find the server on their own.

1 Like

wow thanks a lot for your very detailed reply, will try this right now!
And I am using the dhcp server built in into the cisco switch, is simple and allows me to set the options.

1 Like

The procedure worked, I have finally installed it. Thanks

But in the add phone option, list types only for 79xx series, and all I have are 88xx ones… is there a way to add support for the 88xx ones?


1 Like

You can go to:

  • SCCP Manager
  • System Parameters

In SCCP Model Information, click on “Update Files from Provisioner”
Select your model (88xx) and download the files

After that, enable the phone (click on select and activate)

With this, 88xx phones should appear in the phones list

PS: it looks like the 8841 firmware is not available in the provisioner, but you can download the sccp firmware elsewhere and paste the folder contents into /tftpboot on your server

Just extract the contents of the zip with the 8841’s sccp firmware in the /tftpboot folder, do a fwconsole chown and after that try to enable the phone in the SCCP Model Information tab, it should recognize the files in the tftpboot folder

1 Like

PS²: According to this forum thread: Provision Cisco CP8841 to FreePBX using Chan-SCCP - #15 by tmittelstaedt

These phones do not have SCCP firmware, but SIP - however, the chan_sccp driver is compatible with the sip protocol on these phones - I did a quick search on the internet for the SCCP firmware of the Cisco CP 8841 and found nothing, just sip firmwares.

It seems that in this thread the phone was unable to work with sccp_manager, but I can’t tell if it was using the develop or stable version, it’s worth testing now with develop.

As there is support and an “official” listing of these phones in the manager, I believe it is possible to make them work

1 Like

I was able to find the firmware for the four model of cisco phones I have and you are correct all of them seems to be sip only. Only the spa525 was downloaded using the “update file from provisioner”, but I am not sure if that one is sip or sccp based.

I will try to provision my 88xx phones, now I have the firmwares downloaded to /tftpboox/firmware, but when I go to “sccp → phones manager → sccp phone → add device phone” only a handful of 79xx models are listed there, even if I downloaded the firmware already, or is there another process to manually add the phone type for my 88xx ones?

I appreciate your assistance a lot!

I was able to enable three of the four models that I have, the only one that I had to add manually was the 8845, and I don’t know what “Load information ID” to use, so I came up with a id name that I made up: loadInformation651, is there a way to know which ID should I assign? (see image)

Also, now I think what I need to do is start provisioning my phones or my templates for my phones, is there a guide to do that?

thanks a bunch!

Although they are enabled, the firmwares are not being recognized by the SCCP module, when a phone is enabled and available for use, the background turns green with the firmware information, like this (i activated the 8841 to serve as an example):

I believe that they are not being recognized because they are inside the /tftpboox/firmware folder - my firmwares are only recognized when placing them in the root of /tftpboot, like this:

These are the 7965 firmware files I have on my server
Initially when I put them in the “firmwares” folder it was not recognized by the module nor did the phone have access, so you can test pasting the firmware content directly into the root of the /tftpboot folder

The loadinformation id is related to the firmware that will be installed on the phone, unfortunately I don’t know how to determine the loadinformation id of these phones that are not in the default list of sccp_manager, but I believe it may be related to the file names

About the provisioning template, it must come with the firmware, you can put it in the /tftpboot/templates folder to appear in the manager module, after that you can add the phones using the MAC and it will use this template to send the information to the phones

I put the 8841 firmware files in the root of /tftpboot and did a fwconsole chown, although it didn’t automatically recognize it in sccp_manager when I edited the phone settings for LoadImage to be sip88xx.14-2-1-0201-40, the field turned green and available for activation

Regarding the template file for configuration, I saw that it does not come with the firmware downloaded from the Cisco website, but there is a template model at this link:

You can use this template and save it in the /tftpboot/templates folder and edit the phone configuration in the template field with the name SEP0000000000.cnf.xml_8841_template

The end result should be something like this:

I moved my last question to a new topic since is not specifically related to the original question.

Thanks for the solution provided, it really worked like a charm!

1 Like

I was the one who tried SCCP manager.
I tested with both versions, Stable and Develop.

I have progressed a lot in understanding the phones. Maybe I return to the driver for a second look. But for now it works with patched Asterisk


Probably should be worth mentioning that the “official” download location:

only has a link to SNG7-PBX16-64bit-2302-1.iso

The URL for the version you used in the first post is:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.