SCCP Cisco Phone Paging & Intercom

I saw a post on the TB forum someone trying to get a Cisco SCCP phone working with paging/intercom. Based on the information they provided, I believe the following might provide a general solution:

First, create an auto-answer macro for the SCCP phone that will override the FreePBX defaults in extensions_custom.conf:

[macro-sccp-autoanswer]
exten => s,1(check),ChanIsAvail(SCCP/${ARG1},sj) ;I don't know if this works for SCCP
exten => s,n,Dial(SCCP/${ARG1}/aa=2wb,5,A(beep))
exten => s,n(end),Busy(20)
exten => s,n,Macro(hangupcall,)
exten => s,check+101,Busy(20)
exten => s,n,Macro(hangupcall,)

Next - for each SCCP extension’s device record at the CLI do the following, assume in this case we are setting this for Device (extension) 224:

CLI> database put DEVICE/224/autoanswer macro sccp-autoanswer

Now when you page or intercom that extension, this will override the default behavior and send the appropriate dialstring to the SCCP extension. You simply need to add the info to each extension, which could easily be automated with a very simple module that did this each time such an extension was created.

There lies the problem, all I get when I click pn the custom destination, that is the error I get. I don’t have an option to edit it. I think I will have to delete it from the data base directly.

Thank you. That did the trick.

Free PBX is 2.5.1.0. It is a custom destination. http://www.miketabbert.com/share/customdestination.png When I click on the Grand Central one to try and fix/delete it, I get that error.

I found it, do you have, under Tools, PHPMyAdmin? Start that, go to database asterisk and then click on custom_destinations then on Browse button. You will see your destinations there. And here you can delete the faulty destination.

???

In what module do you get this error? And what version of FreePBX do you have?

I am renumbering my phones, how can I remove this on one extension?

CLI> database del DEVICE/224/autoanswer macro sccp-autoanswer

All I get when I try to run it is…

pbx*CLI> database del DEVICE/102/autoanswer macro sccp-autoanswer
Usage: database del
Deletes an entry in the Asterisk database for a given
family and key.

Any other ideas?

Thanks,
Mike

The correct usage is:
database del DEVICE/102/autoanswer macro

‘DEVICE/102/autoanswer’ is the family and ‘macro’ is the key

That worked. Thank you.

Any idea how to delete this from the database? http://textsnip.com/e854b0

Thanks.

The error is here:
size=15[/size]

You have two ’ in the beginning of the string, that is wrong, remove one and it will work

Just curious, did you notice how the entry look like before you deleted it?

Yes, it did show a ’ in from of the value. So I did mistype it when I entered it.

Hi,

This is working well for me except that instead of a beep the phone (7971) rings 2 short rings instead of a beep, which would be preferred so the receiving end knows it is a page.
Can anyone suggest why?
Are there different settings for 7971s?
I am using SCCP_CHAN_B v3
I assume it has something to do with the line:

exten => s,n,Dial(SCCP/${ARG1}/aa=2wb,5,A(beep))

Thanks,
Alex.

Hi There,

Using this solution, the intercom works great for Cisco 7940 with Asterisk 1.6.2.11 ( and FreePBX 2.8.0.2), but the paging.
Here are the dialplan entries generated by FreePBX and cli output -
Dialplan: (65 is set as the number to page)

exten => 65,1,Answer
exten => 65,n,Macro(user-callerid,)
exten => 65,n,Set(_AMPUSER=${AMPUSER})
exten => 65,n,Set(_SIPURI=)
exten => 65,n,Set(_ALERTINFO=Alert-Info: Ring Answer)
exten => 65,n,Set(_CALLINFO=Call-Info: ;answer-after=0)
exten => 65,n,Set(_SIPURI=intercom=true)
exten => 65,n,Set(_DOPTIONS=A(beep))
exten => 65,n,Set(_DTIME=5)
exten => 65,n,Set(_ANSWERMACRO=)
exten => 65,n,Set(__FORWARD_CONTEXT=block-cf)
exten => 65,n,Page(LOCAL/[email protected]&LOCAL/[email protected],d)

and cli -

Executing [[email protected]:18] NoOp(“SCCP/3-00000017”, “Using CallerID “200” <200>”) in new stack
– Executing [[email protected]:3] Set(“SCCP/3-00000017”, “_AMPUSER=200”) in new stack
– Executing [[email protected]:4] Set(“SCCP/3-00000017”, “_SIPURI=”) in new stack
– Executing [[email protected]:5] Set(“SCCP/3-00000017”, “_ALERTINFO=Alert-Info: Ring Answer”) in new stack
– Executing [[email protected]:6] Set(“SCCP/3-00000017”, “_CALLINFO=Call-Info: ;answer-after=0”) in new stack
– Executing [[email protected]:7] Set(“SCCP/3-00000017”, “_SIPURI=intercom=true”) in new stack
– Executing [[email protected]:8] Set(“SCCP/3-00000017”, “_DOPTIONS=A(beep)”) in new stack
– Executing [[email protected]:9] Set(“SCCP/3-00000017”, “_DTIME=5”) in new stack
== Spawn extension (from-internal, 65, 10) exited non-zero on ‘SCCP/3-00000017’
– Executing [[email protected]:1] Macro(“SCCP/3-00000017”, “hangupcall”) in new stack
– Executing [[email protected]:1] GotoIf(“SCCP/3-00000017”, “1?skiprg”) in new stack
– Goto (macro-hangupcall,s,4)
– Executing [[email protected]:4] GotoIf(“SCCP/3-00000017”, “1?skipblkvm”) in new stack
– Goto (macro-hangupcall,s,7)
– Executing [[email protected]:7] GotoIf(“SCCP/3-00000017”, “1?theend”) in new stack
– Goto (macro-hangupcall,s,9)
– Executing [[email protected]:9] Hangup(“SCCP/3-00000017”, “”) in new stack

Any help would be appreciated.
Thanks in advance.