SBC Silence Suppression


(H.Yavari) #1

Hi to all,

We have a Sangoma SBC in front of our network that it has a trunk to ITSP. We noticed that sometimes incoming calls doesnt have any media and call is silent. So after looking to the pcaps we found sometimes SBC puts a=silenceSupp:off in OK answers to ITSP and ITSP has Huawei SBC that has problem with this option (many same cases over the internet ). We checked the OK that comes from IPPBX to SBC and they don’t have any silenceSupp option !

So there are some questions:
1- why FS/SBC puts this options sometimes??
2- in Media profile, silence suppression is disabled. Then how we should disable this on Sangoma SBC?
3- We found this in /usr/local/nsc/conf/sip_profiles/common/common-base.xml :
param name=“suppress-cng” value=“false”/>

so if there is something here, why FS doesn’t put it in all the calls?

Please share your ideas.
BR


(H.Yavari) #2

Hi to all,

for others that may face with this issue, you should use this in your call routing:
<action application=“export” data=“sip_silence_supp_off_indication=false”/ >

Thank you Mr. Dinesh from Sangoma Support for this hint.

BR


(system) closed #3

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.