SBC External SIP address issue

sbc
Tags: #<Tag:0x00007f24c4acd1c8>

(United States) #1

So I have an issue with calls dropping every 32 seconds if they are started by remote users, and I think the issue is the SIP ack is not being received be the remote user, at least I am not seeing it on a wireshark. What I am seeing is the request from the Remote PC being sent to the wrong public IP address. The address it is trying to send to is an old address from a pervious ISP we had that was removed around the time these issues started.

NOTE: If it makes it easier to track, the external address that starts with 50.200 is the old wrong address, and 152.160 is the correct one.

In the SBC, I found that IP address listed as the external interface (See attachment SIP Profile Status)
So I stopped the profile, went into the config, and changed the external SIP address to the proper SBC address (See attachment SIP Profiles external). Save settings restart the Profile, and to goes back to the old address. (See attachment SBC Profile status detail), but in the actual profile edit screen it shows the address I entered. I tried restarting the profile again, and just restarting the whole SBC

Is there somewhere else the SIP profile would be getting that IP address? I haven’t found it, and i’ve checked my hosted DNS records and I have not found anything pointed to that IP address.

I also noticed that on the SIP Profiles screen for External under Network validation ACL it shows IP address and it is red, is that normal?


(Simon Telephonics) #2

Are you able to SSH into the appliance and grep through the FreeSWITCH config files to see if you can locate the old incorrect IP? If so, maybe that will provide a clue where to find and change it in the GUI.


(United States) #3

I can SSH to the SBC, however my FreePBX/SBC and Linux commands and knowledge are both pretty bad (I inherited this system along with some others with no documentation).

Are their some commands that might help me get to / look through the FreeSWITCH config?


(Simon Telephonics) #4

I don’t know enough about the SBC. I just knew that it is based on FreeSWITCH, with which I have some familiarity. In other FreeSWITCH installations, the config is in /etc/freeswitch and you could use grep -R 50\.200\. /etc/freeswitch/* to see if the IP lives in any of the config files. Not sure that will be correct here. Perhaps someone else will be able to give better input.


#5

As @billsimon said (snap) , mostly the configs would be in /etc/freeswitch so

grep -r "50\.200\." /etc/freeswitch

would likely find it in your External Profile


(United States) #6

I got my answer, it actually isn’t in the freeswitch settings. Rebooting the SBC doesn’t actually reset the settings if you have made the change. You have to just Stop the services, and then restart them, and then your IP address change in the SIP settings will actually take hold.


(system) closed #7

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.