Sangoma VPN One Way Audio


#1

Setup

FreePBX hosted with Freepbxhosting.com

Phones: Sangoma S305

They’re configured with the VPN via the wiki -> https://wiki.freepbx.org/display/PHON/VPN+Setup

The phones connect and register just fine, however there is one way audio.

extension > external = External hears them, they can’t hear external

extension > extension = they can’t hear each other

I’m not exactly sure what setting i’ve got wrong.


(Itzik) #2

Added the VPN range under the local networks?


#3

The tun0 adapter is set as local automatically in the Interfaces section, but I can add the range in the Networks tab as well.


(Itzik) #4

Talking about Settings > SIP Settings in the PBX


#5

Yes it’s there


(Itzik) #6

On the extension, try setting NAT to Yes.


#7

The extensions are using PJSIP so I don’t have that option, I can switch them to Chan_SIP


(Dave Burgess) #8

Save this as a last resort solution. We need to make sure that PJ-SIP is working, and if you’ve found an edge case where it’s having a problem, the troubleshooting you do can fix a problem.

Having said that, however, the assumption with one-way audio is that 90%+ of the time, it’s a NAT setting. With PJ-SIP, some of this goes away, but still the assumption should be that a “local” address is leaking out into a “non-local” space and screwing you up. It might be time for a PJ-SIP Debug session. Turn on PJ-SIP debug stuff and see where the disconnect is. There are supposed to be automatic NAT settings throughout PJ-SIP, but make sure that all of the networks (local, external, and VPN) are all routed correctly and set up to work accurately. Don’t forget that the remote end could be interacting in an “unexpected” way, so you’ll need to pay attention to the other end of the VPN to make sure that the routing at both ends is working.

Now, once you’re convinced it isn’t NAT, check your CODEC details. This is usually easier (but far more rare) in that Codec mismatches show up in the /var/log/asterisk/full log as a notice from the server about not being able to transcode from something to something else.

When responding back, you need to tell us what is and isn’t working, what you tried, and what the result was. Answer that sound like “Nope, guess again” are the fastest way to get people to stop helping you entirely. Yes, it means you type a lot. Sucks to be you, but we can’t really help you unless we know what you know.


(system) closed #9

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.