Sangoma Completes Acquisition of Digium: Sangoma Press Release. Community FAQ: Sangoma and Digium Join Together FAQ
FreePBX | Register | Issues | Wiki | Portal | Support

Sangoma template not uploading to the s500


(Mike) #1

Using FreePBX 14.0.3.13 - Firmware is .54
Voip Newbie here with a problem I just can’t figure out myself. I have the Sangoma s500 phone working great except that I can’t get the Sangoma s500 template to upload to the phone
I purchased the Sangoma’s so I could use the Phone Apps & End Point manager. Just tell me what you need to see so I can get the APPS working. It has to be a config problem somewhere but I don’t know where to look?
Thanks!


(Itzik) #2

I’m a little confused. Is the phone working with Endpoint Manager, or not?


(Mike) #3

I believe it is, I have Extension Mapping working. Just doesn’t do anything when updating phone with template?


(Tony Lewis) #4

You need to tell the phone how to reach the PBX the first time. Have you done that?


(Mike) #5

I’m not sure?


(Tony Lewis) #6

Please go review the getting started guide for phone in the wiki.


(Mike) #7

You need to tell the phone how to reach the PBX the first time. Have you done that?

I don’t really understand what you mean? I can do everything with the phone except upload template to phone?


(Itzik) #8

Mike,

We want to help you here…

Did you provision the phone with Endpoint Manager, or you manually registered the phone?

https://wiki.freepbx.org/display/PHON/Getting+Started


(Mike) #9

I used Endpoint I think? I have just been completely confused with all this provisioning & deployment stuff my head hurts.
Telling me how to I know if the phone is provisioned or where to look would help. I have gone over the WIKI several times & it just confuses me more…
Sorry, I’m a complete noob on this PBX stuff. I will be happy to show log files, screenshots, whatever yall need!


(Mike) #10

With the phone GUI opened from it’s IP address & looking at Management > Auto Provision -
Firmware Server Path = https://rs.sangoma.net/firmware
Config Server Path = https://rs.sangoma.net/cfg

Is that ^ what should be here to connect?
Looking at WIKI it should be like this : `0e351a4e:d07ef38ad0e35982@server.example.com:1443


(Itzik) #11

If you use zero touch provisioning https://wiki.freepbx.org/display/PHON/Auto-Provision+Quick+Start+Guide

If not: https://wiki.freepbx.org/display/PHON/Setting+Configuration+Server

Only if you have Sys Admin Pro and you set http auth then yes: https://wiki.freepbx.org/display/FPG/System+Admin+-+Provisioning+Protocols

If not, it should just look like outlined here https://wiki.freepbx.org/display/PHON/Setting+Configuration+Server

If you are using HTTP for the mode you will need to set the Port Number that your PBX is setup to listen on for HTTP provisioning as shown in the Global Settings section of End Point Manager.

Example would be http://10.10.48.2:84 with 84 being the Port Number

IMO: everything is very well documented in the wiki. start with the getting started guide, and go from one link to the next. (in a order)


(Mike) #12
  • I used Zero touch provisioning
  • I have Sys Admin Pro and set http auth to use HTTPS on port 1443
    so I need to change

have Sys Admin Pro and you set http auth to be like this : `0e351a4e:d07ef38ad0e35982@server.example.com:1443


(Itzik) #13

Do you have in the Sangoma Redirection Portal the phone looking to https://0e351a4e:d07ef38ad0e35982@server.example.com:1443 ?


(Mike) #14

Yes, and it’s polling


(Mike) #15

deployment at sangoma portal


(Lorne Gaetz) #16

In addition to the phones tab being populated for the deployment, you must also edit the phone page in the portal to redirect to the deployment.


(Mike) #17

Phone Tab at portal

Curious why the DECT base is not polling?


(Itzik) #18

when you ping the fqdn does it resolve to your wan IP?

Also did you forward the ports to your PBX?


(Mike) #19

Freaking Crap! Can’t post for 21 hours because I’m new user???
That’s BullSDhit!!!

Ping resolves to my IP

Explain please? In my firewall > port forward?


(Itzik) #20

Yes. unless you have this phone and the PBX internally then replace in the Sangoma portal the fqdn with the PBX IP. That way the phone will ask the PBX for config without needing to forward ports.

Also, you’ll have to update the string in your Endpoint manager template. Can you post a picture from that as well?