Sangoma Talk will not register with firewall active

I’m running into some issues with the system firewall not playing nice with Sangoma Connect.

If I disable the system firewall, everything works. When the firewall is re-enabled, everything works for a short while, then it is back to the registering loop.

I assume this is because the IP the mobile device is connecting from is not allowed through the firewall. With the mobile device having an IP that is unknown to me, is there a best practice to provide system security but still allow random IPs with valid credentials to auth?

EDIT

Nevermind, I’m a fool and did not have responsive firewall enabled for pjsip. As soon as I enabled that, it allowed registration attempts and all is right with the world.

1 Like