Sangoma Talk - Mobile to Mobile, no audio

Hey guys, I’m having a really hard time sorting this one out and could use some help and guidance.

I have 2 PJSIP extensions configured as Sangoma Talk on iOS. I have all the required ports open on my firewall and I have entered a STUN Server as part of the configuration.

Calls from and to chan sccp extensions to the Sangoma Talk Mobile extensions work fine, but calls from one Sangoma Talk extension to the other have no audio… yet signaling works fine.

Any clues as to what I should be checking next to fix this issue?

Many thanks - Anton

Experiencing the same no audio in Sangoma Talk for a week now across a couple of different system at least. Opened a support ticket with Sangoma support but no resolution or lead on the issue yet.

Are you experiencing this issue across both iPhone and Android phones? Have you tried testing while not being connected to a wireless network on any of the phones?

Zero issues with Sangoma talk here and I/we use it daily…

Yea, it’s not happening to all of our users. It’s a small subset that we are experiencing it with and it’s disparate across different systems that started a couple of weeks ago.

We have many users that are working just fine as well but it seems to be limited to a small subset of them that I am trying to figure out the common thread among them.

Right now we are able to replicate the issue on iPhones that are connected to a WiFi network (any WiFi connection even a hotspot on another phone). The audio is present if we connect over a cellular data connection.

No idea if we are on to something there or if it’s just another red herring.

So, further to my last, I did a bit more digging. Firstly this is the Sangoma Talk mobile app running on iOS, we don’t have any Android devices to test. All the extensions on our PBX are SCCP using Chan-sccp-b, except for the two PJSIP extensions running Sangoma Talk. I have configured a STUN server address. Calls originated on an iPhone to any other internal extension work fine. Calls from any SCCP extension to an iPhone work fine. Calls originated on an iPhone to the other iPhone have no audio. Calls made from an iPhone to the any of the PBX’s external DIDs, not using the Sangoma Talk app, can be answered and transferred to the other iPhone’s Sangoma Talk extension without issue. However, when a call originated on an iPhone Sangoma Talk extension does the same thing, there is no audio on transfer.
This has never worked, so maybe it’s a FreePBX configuration issue, but I’m not sure what could be mis-configured.
Hope this helps clarify.

We are experiencing pretty much the same symptoms, except for us it’s always worked. This is the first one where this is an issue.

Are your iPhones on the same LAN as the phone system or are they all remote?

For the two iPhone extensions, on the Advanced tab, try setting Direct Media to No.

If that’s not your issue, with pjsip logger turned on, paste the Asterisk log for a failing call at or similar and post the link here.


Wifi or cellular, same LAN, or different, still get the same behavior.

What made somewhat of a difference for us but hasn’t really fixed it is setting the STUN server for each individual user.

Go to Admin → User Management → < relevant user > → Sangoma Talk and enable the Advanced mobile app network settings to the following.

I am pretty sure you’ll need to reset the application and have the users re authenticate to get the new settings.

This allowed some external phones to hear audio again but it’s a very ugly workaround that broke things like LAN communication unless you have an internal DNS server or NAT loopback properly setup on the firewall that handles the connection.

It also sucks that this is a per user setting.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.