Sangoma Talk Desktop connecting forever

Another update? Worked fine a couple days ago. Now when you open it you get connecting forever. Sangoma support is also stuck

1 Like

I’m experiencing this same issue.

Hopefully be fixed tomorrow. I have a ticket open with Sangoma and we worked on it an hour today with no solution

If they get it fixed please post the solve if you don’t mind. I haven’t had a chance to open a ticket yet, but that’s on my list for later in the week.

Curiously, if you login to UCP is the standard webRTC phone working? I don’t really use webRTC in my system as we prefer the full Windows and Android soft phones, but I noticed webRTC is not working either now.

Sangoma Connect on Android is still working oddly enough, but not the Windows client.

Issue resolved. Maybe an update? We had a conflicting port on the PBX. HTTP prefix was set to 0 in Advanced Settings where it shouldn’t be set.


Thank you! That was my issue as well. This must be related to a recent update as I did notice it started for me after a yum update was run. Removing the 0 corrected the issue.

Glad to help. I was stumped. Gotta share the love! Jack Campbell at Sangoma resolved this so I can’t take the credit.

1 Like

Thank you for this post. We were having the same issue for days. Spent hours with Sangoma Support to no resolution. One of my helpdesk guys found this and saw that our HTTP Prefix was also set to 0. He removed it and saved and BAM the softphones started working again.

You are very welcome :slight_smile: We are all a team!

I had the same issue where that value was changed. I’ve also noticed that the Firewall got disabled and that a new administrator named ‘Sangoma’ was created which I assume is not supposed to be. Does anyone else had a new Administrator created?

Edit: Another setting was modified: ‘Allowed Origins’ under REST Interface was changed to * instead of default

It looks like your system was compromised. Not sure that it has anything to do with this particular thread though.

I’l noticed the new Sangoma admin in my system as well. I have a feeling that was added as part of an update.

Not sure how your firewall module got disabled though.

The Sangoma admin is definitely not part of an update and in other instances has been a compromise indicator.

Thanks for confirming. I manage a few FreePBX system and it seems a few of the were compromised after the firewall got disabled. I added a check now to be alerted if the firewall gets disabled.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.