Sangoma talk configuration problem

When I try to generate certificate for sangoma talk configuration, it is giving the following error:

“cannot set certificate - deployment not registered yet”

Any ideas how to fix this?

Have you registered your machine to your Sangoma account? Look at Admin > Sysadmin about registration

Yes, I have. In fact, sangoma talk was working fine was a year. Then, I let the license expire by mistake. Even after license renewal, the user was having problems. So, I tried to make some changes to the “Run domain action” and “Run cloudconnect agent action” buttons. Now, Cloud connect agent is not running and I have been unable to generate certificate or enable sangoma talk.