Sangoma SBC fails to make outbound calls to Sipgate SIP trunk


#1

We have a FreePBX connected to a Sangoma SBC, which is in turn connected to a Sipgate SIP trunk. SIP trunk is registered, and we can make inbound calls through the SBC to FreePBX and answer them with audio.

When trying to make outbound calls, Sipgate is rejecting them with a ‘403 Forbidden (check from field)’. Looking at the from field I can see it is from 447084081234@sipconnect.sipgate.com:5060 I believe it should be MY-SIPGATE-USER-ID@sipconnect.sipgate.com:5060. But I don’t seem to be able to make this happen.

Any clues?


#2

I know nothing about the SBC, but did you confirm that the From header sent to the SBC has your user ID? If it doesn’t, confirm that your trunk has From User set to MY-SIPGATE-USER-ID (pjsip) or
fromuser=MY-SIPGATE-USER-ID
(chan_sip)

Also, do you know where the 447084081234 came from? That smells like a mobile number so it’s unlikely the calling number. It might be the called number, but it’s really bizarre that the destination number could end up in From.


#3

Hi Stewart, I was thinking exactly the same thing actually. (By the way, the 44708… was my typo. Should have been 44870… which is the Outbound Caller ID in the trunk config.)

So anyway, I just copied and pasted the complete SIP settings from the Trunk that I had working direct with Sipgate, to the trunk that I have connetced to my SBC, and I just changed the host ip address to the SBC, and bingo. It started working, and the from ID is now correctly formed.

Happy days!


(system) closed #4

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.