Sangoma s705 soft buttons not working, seems restapps may be the issue


We just deployed our first Sangoma phones, most of our extensions are using Polycoms. We are using the commercial version of Endpoint Manager, and the default sangoma template worked great for registering the new phones. However, the soft buttons on the Sangoma s705, where the user can set call forwarding, DND, and the other similiar functions, are not working. The only soft buttons that are working are the first three, which are assigned as lines in the template. Pressing any other button gives the error “Failed to load xml file!”

I followed the guide on this page, but I’ve reached the end of the page, and no more fixes are listed: Phone Apps FAQ - Phones - Documentation
The last line of the guide says:
If you get nothing returned, this means your port is either not opened on your firewall or not defined correctly. Try and resubmit the Port Management page in Sysadmin by pressing the Submit and Apply Config buttons.
This is my issue. I load https://FQDN:2443/applications.php/donotdisturb/main?user=6105 and the page is blank.

I confirmed that the FreePBX firewall is not enabled. The phones are on the same subnet as FreePBX, so there is no firewall between them, and the phone registration works fine, so there isn’t any connectivity issue.

I found another forum post that said https was required. When I first started troubleshooting, we were using http. I installed our certificate and switched restapps over to https port 2443, but I still get the same issue. I tried running “fwconsole restart restapps” which seems to succeed, but didn’t change the issue.

I’m not sure what to try next, or where to find more specific error messages. Is there a log file that will show restapp errors? What are the next troubleshooting steps?

Thank you

I’ve ran into similar issues before, and found that I had to make sure there was a user assigned to the extension. And that the group or user was given permission to use Phone Apps. Otherwise, it will be a blank page.

Extension setting:

User Management Group or User Setting:

Hopefully that helps.


1 Like

Greetings Chris,

Thank you very much for your detailed response!

I went to attempt your solution, but my system is missing the menu that you show in your screen shot. After looking around, it appears that this may be the issue:

I tried running updates, but all modules are up to date. However, the description of the Phone Apps modules says: COMMERCIAL MODULE REQUIRES A LICENSE FOR IT TO FUNCTION. Applications using the RESTful API.

Do I need to purchase the Phone Apps commercial module to make this functionality work? I thought I read somewhere that Phone Apps comes with the Sangoma phones, is this correct? If so, is there a license key or something that comes with the phone purchase?

This module needs to be installed, does this do it?

fwconsole ma install restapps

When I ran the command, I get this error:

Detected Missing Dependency of: endpoint 15.0.25
Downloading Missing Dependency of: endpoint 15.0.25
The following error(s) occured:
Retrieved Module XML Was Empty
Unable to resolve dependencies for module restapps
Updating Hooks…Done
Chowning directories…Done

Current version of EPM is, so you’re way behind. If you’ve paid for EPM, then your maintenance period has probably expired. How to Renew FreePBX Commercial Modules Maintenance - Sangoma Portal/Store - Documentation

Greetings Igaetz,

You are correct! Apparently we haven’t paid for EPM support since 2015. I just renewed support. I then ran the command “fwconsole ma install endpoint” and it gave this message:

Checking database tables…Done
Migrating tables as required…Done
Checking Settings and Defaults…Done
Generating Configs…Done
Downloading Firmware…Done (Background)
Generating CSS…Done
Module endpoint version 15.0.23 successfully installed
Updating Hooks…Done
Chowning directories…Done

I also tried updating via the module admin in the GUI web interface, but it doesn’t recognize any EPM updates. Is my EPM so old I can’t update it? Does it take a while for the system to recognize that support has been renewed in the Sangoma portal?

It does, but you can force a license resync and install with:

fwconsole sa update
fwconsole ma downloadinstall endpoint --tag 15.0.46

Thank you for those commands!

I was able to install the most recent versions of restapps and endpoint manager. Tomorrow we will try the original fix to see if the s705 buttons start working.

Thank you for all the replies so far.

I still have the original issue, where the phone apps on the Sangoma phone do not work. Progress has been made. Now when I load https://FQDN:2443/applications.php/donotdisturb/main?user=6105 I get an xml display. When I load this in a computer browser, part of the message is “Phone Apps module not licensed.” This is to be expected, since we do not have, and as far as I know, do not need a phone apps license for Sangoma phones. However, the phone itself still show the error “Failed to load xml file!”.

I compared the extension settings and the user manager settings to the screen shots Chris supplied above. I do not have the extra group that Chris blacked out, but other than that, all the settings in both menus match exactly. The linked user is the default user created when the extension was created. Do I need to create a new user to use these apps?

I’ve looked through the extension settings, the user manager, and the endpoint manager, as well as through the guide I linked above, and I cannot find anything amiss. Is there a log file on the phone or the PBX that can give me a better error than “failed to load xml file!”? What are the next steps to try to get these phone apps to work?

Thank you

With confirmation that the issue persists once you’re on the most recent version, next step is a support ticket. How To Open A Support Ticket - Sangoma Portal/Store - Documentation

Thank you, Lorne,

I’ll open the ticket. If we do work out a solution, I’ll try to post it here, for posterity.

Sangoma support came through for us!

Apparently, despite the link above working, the restapps daemon was not running on the FreePBX server. Support said to use this command in the Linux shell to start restapps without interrupting phone calls:

fwconsole start

We also had to use the endpoint manager extension mapping to apply the updated config to the Sangoma phones using the “Save, Rebuild Config(s) and Update Phones”.

Once these two steps were complete, all of the soft buttons on the Sangoma s705 phones started working.

Thank you to everyone who helped us to get this fixed!

That’s good news! I’ve also ran into some updates causing the daemons to stop and had to run an fwconsole start to get them running.

Glad it is fixed!


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.