Sangoma S705 Provisioning bootloop?

Hi all,

i just got my Sangoma S705 and i made a template in epm (tried internal and external)
made a extension mapping and such.
registered the phone in sangoma portal and setup the redirect (working because the poll count is going up and i can see my WAN IP.

in provisioning protocol i selected HTTPS only. (also in port manager i made everything https, including the rest apps and the https provisioning)
so all my firewall rules are sound and working.

when i boot my phone it is getting a IP,
checking and retreiving for for config files
background image and ringtones.
but then it checks for firmware and after that it just restarts the entire initializing process all over (without the boot logo)

it just continues to do this.

anyone have an idea what this might be?
and how to solve it

Factory reset your S705. Provision the phone on your LAN 1st with latest firmware. Then all your remote / one touch provisioning will work as long as your config is correct.

The boot loop was a known issue. New firmware fixes the issue your having.

If you can’t get the phone to your LAN. Factory reset the phone but don’t let the phone upgrade firmware in endpoint manger. That should alow you to use the phone until you can get it to your LAN for the firmware upgrade.

1 Like

So i did boot the phone without a LAN cable and then it booted… i then connected the lan cable and trough the gui i updated the firmware (rom) to the latest found on the sangoma wiki
(it updated the ROM but not the BOOT (boot is still from 2017 and rom is now from 2021)i assume that is correct.

i deleted the Firmware from slot 1 in the endpoint manager and rebuild the config.
then i rebooted the phone to factory reset.

but it still keeps going trough the initializing fase non stop.

on the sangoma portal side all is good because i can see the poll counter going up (so there is a connection there)

i also tried http and https (in provisioning protocols and in the template in epm)
i also tried internal and external (the phone is on the same lan as the freepbx server)

still nothing :frowning:

You are working multiple issues. 1. Router Portforwarding configs 2. Firewall on router config 3. PBX config 4. Firewall on PBX config 5. EndPoint Manager config 6. Phone provisioning 7. Touchless phone provisioning. Extra extra…

So we need to step back a few steps. In order for me to help.

What is your experience with freepbx? How many phones have you got to register in the past? Have you watched the crosstalk YouTube vids?

I have been through your re-boot issue. Your phone is trying to upgrade using bad firmware that is still on the phone.

Let me start at the beginning then

I am a N00b with Freebpx, for now i am learning but soon my cousin that has a company wants me to set this up for him with 30+ employees (that is going to be 20 softphones and 10+ hardphones

My go to guide is Chris Sherwood from Crosstalk Solutions on youtube
to be precice i followed the “Freepbx 101 v15” from beginning to the end.

I have a “on premise” setup that is running virtually (yes it has its own dedicated LAN)
my network on premise is Unifi (udm pro) the VOIP network has its own Vlan (80) and the ISP modem is in bridge mode.
the unifi firewall turned off sip alg (because i had 1 way speech with the softphones before)
my expertise level with networking and such is Windows Certified IT administrator

so portforwarding is setup fine (all ports needed are open)
firewall is setup fine (the voip network is isolated from the rest of the network but has full internet access)
Freepbx is setup fine (exactly like in the crosstalk series)

i use the Clearly IP module for softphones (1 registered now for testing purposes and this works flawless)

For the hardphones i first bought a Yealink T48S and that worked fine BUT i did not want to do things manually or buy the epm licence and phoneapps licence so i decided that the Sangoma phones were a better match so i changed that for the Sangoma S705.

I bought the Sysadmin pro and off i went with the EPM (again exactly like crosstalk solutions)

Here is some info about the current phone after i updated it yesterday (like you said)

Firmware(IMG) : 17:11:00)
Firmware(BOOT) : 13:37:00)
Firmware(ROM) : 17:11:00)

Free pbx situation :

1 trunk to a provider
1 DID number going to 1 extension (200)
the softphone is on extension 200, the hardphone will be on there to.

Sangoma portal situation:

all is setup fine so the pbx server under phones has the https redirect to my Wan
and the phone is pointed at my deployment (pollcounter going up so it connects with the phone)

in short, using the softphone (and the yealink before) i can call out and receive calls
so that all works fine.

  1. router portforwarding is fine
  2. firewall on router is fine
  3. pbx config is fine
  4. firewall on pbx is also fine
  5. EndPoint Manager (should be fine as it is an exact copy of crosstalk)
  6. Phone provisioning not fine… not working

i hope my rambling helps you understand a bit better :smiley:

I’m experiencing the same issue with a S500. From a factory reset state, if the option for firmware checking is set to “always check firmware version”, the phone will enter a boot loop just like you described. The strange thing, at least to my understanding, is that in my support ticket the phone was deemed faulty, but aside from that, the phone works fine if any other of the two firmware checking options is selected.

1 Like

oh so maybe the phone is faulty then… because everything is setup just fine (as far as i know)
I opened a ticket with number 1027830 at the sangoma support desk.

i hope they answer soon (after the weekend ofcourse)

I doubt this is the case with an on premise pbx but you’re not by chance trying to use the built in OpenVPN server are you?

I’ve run into issues with D series phones (even brand new ones) that had too old a firmware on them to work with OpenVPN. They would connect to EPM and then indicate they were updated the firmware but in reality they were grabbing the OpenVPN configs first. The issue was that the currently installed firmware was incapable of OpenVPN so the phone would just go into a nonstop reboot loop.

The solution was to remove OpenVPN from the extension mapping config, let the phone boot without VPN, grab the latest firmware and then reboot. After connection I re-apply the OpenVPN settings and it all goes well from there.

1 Like

Hi Ashcotech,

no i do not use the open vpn server (in extension mapping vpn is set to “no”)
my install is very basic i only made the admin dashboard https via letsencrypt
and under Sysadmin pro - vpn - that is set to disable
but even so the range is internal

and i did update the phones firmware to the latest first and now one version before that (makes no difference)

funny thing is that it does connect to the sangoma rederect servers because the poll counter goes up.
it just keeps booting after firmware check

i did also check what @arielgrin said and turned off the “always check firmware”
and then the phone boots but it skips the “retreive config from sangoma” all together so the phone does not provision.

but ofcourse the point of zero touch provisioning is well… no touchy… and i am touching allot and still no luck :stuck_out_tongue:


i pulled my hair out so i did the following

Added my neighbour WAN to the (local) firewall rules
and reset the phone to factory reset at his house…

works first try.

now i am back at home plug it in and it also works

so now i am confused… so local (on the same network doesnt work) but in a different lan it does :confused:

but all is fine now even after a factory reset

i want to thank you all for your time and patience @idho0618 @arielgrin @ashcortech

If you have a DHCP option 66 string on your local LAN, that might explain why it works in one location and not the other.

1 Like

I have lots of s705 deployed…both on local lan same as on-premise pbx and remote. All use Sangoma redirect, HTTPS, EPM…zero issues provisioning and updating…you have something setup wrong…whether in your edge device, pbx, or both…

There was some bad firmware out there.

My suggestion is the same.

Please get the s500 to the same LAN or VLAN you have your PBX on. Get the newest firmware installed in endpoint manager, Factory rest the phone, and register the phone via your local LAN or VLAN for the 1st time. That will stop your boot loop. This assumes you have your 1. router port forwarding config(s) 2. firewall on router config(s) 3. PBX config(s) 4. firewall on PBX config(s) 5. EndPoint Manager config(s) 6. Phone provisioning config(s) 7. Touchless phone provisioning config(s). extra, extra correct.

Yuppers! That is the fix! Again, it comes down to provisioning the phone for the 1st time on the local LAN or VLAN.

I agree with defcomllc.

When I was first learning FreePBX, while I was trying to figure out the boot loop issue(s) with the “S” series phones I was having, which are the same issues as the ones listed above, I was also learning that I had config issues with my 1. router port forwarding config(s) 2. firewall on router config(s) 3. PBX config(s) 4. firewall on PBX config(s) 5. EndPoint Manager config(s) 6. Phone provisioning config(s) 7. Touchless phone provisioning config(s). extra, extra.

If you are trying to get remote phone provisioning to work w/ VPN and without as defcomllc noted it “DOES” work fantastically. As folks who have had our PBX’s stable for a long time we have to remember that if things are off, even just a little bit, they will not work as expected.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.