Sangoma S505 with EXP100


#1

I’m trying to connect a sidecar to a S505. I have the phone configured to get the config files from the freepbx server and that part is working fine. I have the config settings so that GUI Override is set to Config File (that is the default setting). The phone does connect to the server and download the settings just fine with one exception. The setting for the side car to actually work. The setting is under Settings/Advanced Settings/Network/PC Port and the options are: 1.Bridge mode, 2. Router mode, 3. Connect to module.

I change the setting on the phone to option 3. Connect to module. The phone then reboots, the display shows that the setting has in fact been changed and then reboots again, but this time the setting has reverted back to the original Bridge mode setting.

I can’t find any options in the Endpoint Manager that have anything to do with this setting.

Is there a setting in the config files that might be over riding the phone setting? I don’t know what the number associated with this setting is so I can’t verify the config file might be overriding the phone setting.

Help! How do you fix this?

Thanks,
Jay


(Itzik) #2

Open the file in /tftpboot see how is set there.


#3

Thanks for the reply. There are many files in /tftpboot. I had already thought of that but my issue with config files for the sangoma phones. they are xml files and have things like:

<p64>14</P64>
<P42200>14</P42200>

I have no idea what any of the codes are. Aastra phones had human readable config files, the Sangoma ones don’t.

There don’t appear to be any settings in Endpoint manager for this option either so there shouldn’t be anything in the config file to change it.

Does that make sense?

Thanks,
Jay


(Techer) #4

https://wiki.freepbx.org/display/PHON/Sangoma+P+Codes


#5

Sweet! Thanks,

So a quick lookup in the pcode list has the port option as . I looked in the config xml file and there is indeed a P231 section with it set to “1”. I need “2”. A quick check of the basefile shows

"<P231>__pc_port__</P231>"

So my new question is: "Where is pc_port exposed in the GUI so I can make a change? I’ve looked through the endpoint manager and can’t find anything to do with pc_port, what/where is this setting?

Thanks,

Jay


(Dave Burgess) #6

It may not be, directly. It’s possible that you’ll need to make this change in a basefile edit.


#7

I can’t believe that they don’t have it exposed someplace. Why would they put in a variable like that if their intentions were to expose it to the GUI so you could set it? Now, I certainly could believe that somewhere along the line, they forgot about this setting and didn’t expose it to the GUI. I’ve lot track of things, it’s not that hard… I did find in the wiki that __pcport__ is listed for the Htek phone and there’s nothing for __pc_port__ tagged for Sangoma. This is why I think they forgot about it.

I’d bet that anyplace using the Sangoma phones has the GUI over config files set and then just go make the necessary changes in the GUI on the phone and be done with it.

If there isn’t a reasonable response from support about this, I’ll probably open a ticket to get them to expose it in the FreePBX GUI. I’m just surprised that it’s been hidden for so long.

Jay


(Alex Fassas) #8

I believe that Endpoint Manager handles the PC Port setting for you when you configure the Extension to have an EXP100.

From FreePBX Admin GUI, Endpoint Manager -> Extension Mapping.
Select an Extension to edit.
In Extension Edit dialog, under Expansion Module 1, click on drop down box. Select EXP100-1. At bottom of dialog, select Save, Rebuild, and Update Device, then Apply.

That is all it takes.


#9

Thanks, I completely forgot about that section.

Jay


(system) closed #10

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.