Sangoma S505 VPN connected remote phone reboots every 16 minutes

Remote worker, s505 phone, phone is VPN connected to FreePBX server running v.
It REBOOTS every 16 minutes or so. On call or off call, seems to be on a schedule.

I can’t find any setting in the phone or from the configuration side in FPBX that should be causing a reset every 16 minutes.

Does anyone have any idea what I should look at?


How is it powered?

It is powered by AC Adapter, not PoE

You could start with the easiest piece and see if a new adapter would make a difference. You could also check to make sure that the phone has the latest firmware installed on it.

Otherwise you’ll probably need to look through the asteirsk logs at the exact time it happens each time and see if there is any pattern to it. Like is it rebooting EXACTLY every 960 seconds on the dot?

It really is every 16 minutes

Yea, that’s weird. I don’t know of a settings in Asterisk or the phones that would do this. Are you certain that it reboots? Is it maybe the VPN that’s disconnecting and reconnecting?

If it’s actually rebooting I would look into the power adapter or something physically with the hardware of the phone.

Yes, definitely restarts (or at least reloads configuration).

We can try another adapter. Probably another phone too.

Yea, I don’t know what else to look at but the hardware or something in the environment where the phone is.

Is it just one VPN phone, or are there other VPN phones that work fine? What is the IP lease/reg time set to?

Can’t remember if there is a “check for updates every x” setting, but maybe that could be it?

Can you pull logs off that phone?

It is a single phone in a home office for a remote worker.
I haven’t checked the lease time, i’ll do that… that would be in FPBX.
I’m not sure if i can get logs off the phone from here or not.
I haven’t seen any options like check for updates that had a time in that 16 minute range.

Also anything unique to that user’s setup of their local network.

I have the phone in my office now, not JUST plugged into power (a different power cord) and it still restarts.
As far as a phone log, I haven’t found it yet.

Factory reset it and let it just sit there on factory settings to see what happens.

Ok… a totally different phone, new out of the box, does the same thing, once i get it connected via VPN.

My setup process is to connected it locally, get a good configuration, test it, then enable VPN.

I have now factory reset one of them and will see if I can connect to the VPN without loading a config locally first. I’m not sure that’ll work, but i’ll try it. Well, that was short-lived… check config file error.

Even with the phone disconnected from the internet, it restarts on schedule.

I am honestly not sure I’ve ever seen that.

Are you at the latest firmware on these phones?

They were not on the newest. Now they’re on…
Same problem
so weird.

I’m working on other solutions.

I once had a similar problem with a phone using openVPN. The phone would work fine on the local network, but would restart like clockwork every few minutes when connected through the VPN. The problem turned out to be that the same openVPN credentials were on two different phones. Once I changed the vpn credentials the phone worked normally.

Final update. I found a non-OpenVPN solution by running it over our branch-office vpn between firewalls… which I wanted to do in the first place, but that gave me issues and the openvpn was a quicker solution… until we discovered the regular rebooting.

Now it’s happy and i turned off openvpn on the server.

Thanks for the ideas even though the original issue didn’t get solved.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.