Sangoma S500: only one side of a call ban be heard


(katherine Moss) #1

I have a very weird issue; after installing a fresh FreePBX server (FreePBX 15 according to the installer), we have two phones currently connected to the system; one of them, an S300, will connect and pull its configurations from the Sangoma Redirection Service, and then finally bind properly to the PBX server. The other, which is an S500, will not automatically pull configurations. It worked once, on a different network site, but will not work at mine, and this is after resetting the device several times. After manually configuring the device by entering in all settings, it will connect, receive calls, though with one problem. Those trying to call me can’t hear me. I can hear them, but not the other way around. This occurs regardless of which codec is used. advice would be great. Thanks.


(Itzik) #2

One way audio is usually a NAT issue.

Can you describe your setup a but more?


(katherine Moss) #3

It is as follows; router has two switches connected to it; the phone is connected to my smaller eight-port switch which has PoE on it. Network is run via Ubiquiti if that matters. I am not behind a NAT configuration, though there is a site-to-site tunnel connecting my site to the one where the PBX server itself resides.


#4

You probably need to check the SIP configuration on FreePBX and make sure that the network where the remote phone is connected to, it is set as a local neteork and a trusted network on the firewall module.


(katherine Moss) #5

I will update you when I can check on that.


(Phill Fernandes) #6

How is this done? Each time I try to add an entry for the other zone it just overwrites the first. I seemingly can’t add both.

SIP ALG is also disabled on her USG 4P.


(Phill Fernandes) #7

For ease @Cambridgeport90’s extension is 1025. I will use that from now on.

1025 can NOT be heard; can hear when calling other extensions.
1025 can NOT be heard; can hear when calling outside numbers.
1025 Voicemails don’t seem to be saved; probably due to lack of audio.


#8

There should be a plus sign to add additional networks.


(Phill Fernandes) #9

What are you talking about? Other than the big green button with the white plus?

If so, I click that and it overwrites what was previously entered and saved.


(Itzik) #10

Where are you trying to add the subnet?

Which version of FreePBX are you using?

Are you registering via the local IP or the WAN IO?


(Phill Fernandes) #11

It’s funny you ask the question of subnet because this actually appears to be a deeper issue then just the phone connecting to the PBX. Traceroute from devices reveals a single hop from the network in question (10.23.98.0/24) to the server using the PBX’s WAN IP. It acts like it’s going over the Site-to-Site tunnel even when the tunnel has been stood down.

A traceoute from 10.23.98.0/24’s router exhibits proper routing and ping behanviour.


(Itzik) #12

I don’t care how funny it is.

Please answer: Did you register this phone against the WAN IP of the PBX, or the LAN IP?


(Phill Fernandes) #13

WAN IP no, re-read my point about the traceroute.

LAN IP yes but with one sided voice.


(Itzik) #14

Did you add both networks here?


(Phill Fernandes) #15

Where is that interface?

SNG7-PBX-64bit-1910 // FreePBX 15 // Asterisk 16


(Itzik) #16

Settings > Asterisk SIP Settings


(Phill Fernandes) #17

10.23.98.0/24 is not added as a network in the Asterisk SIP Settings. I don’t understand why I have to add it. I shouldn’t have to, I have another location with the same config and it works perfectly fine.


(Itzik) #18

You need to add the local network the PBX is on, and any local network a phone is connecting from to the LAN IP of the PBX


(Phill Fernandes) #19

I will try this when I get home from clinic today. I am skeptical though as the same config works for the other site without the addition(s).