Sangoma s305 & s405 connected call outbound CID

Hello Everyone,

I was curious if its possible to change Sangoma s305 & s405 phones to show the dialed number when the call is connected? Instead of the outbound CID being used?


Sounds like you have configured your trunks with ‘trust rpid’. Does disabling that yield the desired result?

1 Like

Interesting. I tested this on a 2nd Freepbx server. The 2nd server shows the dialed number instead of the outbound CID. I checked the trunk RPID settings on both servers. Both are the same “disabled”. Both servers are using the same SIP trunk carrier.

I found the problem. The “Send RPID” was set under the extension to: Send P-Asserted-Identity header.

I set it to NO

Now it’s working as expected.

Thanks @lgaetz

Unfortunately setting the extension “Send RPID” to “no”. Now breaks showing the external caller ID when picking up a parked call.

When picking up parked call it show’s the parking slot # (71) instead of the external customer CID. Any ideas? @lgaetz

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.