FreePBX | Register | Issues | Wiki | Portal | Support

Sangoma S300 Locking Up


(Samuel Zuback Jr) #1

Is there a bug somewhere within the firmware for Sangoma phones that is causing the S300 to lock up and reboot at button press? I have installed Firmware update 2.0.4.24 because it seemed the most stable at first. After going live with it, it has still caused the issue. Originally, I had no firmware updates installed through FreePBX. Last week, we decided to push the firmware through to the phones to eliminate problems. 4.25 caused the freeze and the new 4.26 has not fixed it. I rolled back to 4.24 and it seemed fine after some button mash testing. I forced the update across the board thinking it was fine and now it is doing it again. Is there anything I may need to know in order to operate this firmware?


(Tony Lewis) #2

We have tens of thousands of those phones in production and I have no single ticket or complaint on lockup issues. Seems something somewhere with your setup is not correct or you truly found a bug nobody else has found yet. I suggest opening a support ticket and they can assist you.


(Tony Smiraldi) #3

Hi there,

That’s interesting because back in December I opened a ticket for the same problem. After several troubhleshooting attempts, support suggested I RMA the phone, an S300, so I did. Received the new S300, worked fine for about a week or so, now back to locking up and rebooting daily. Support thought maybe something with my internal network. I’ve checked just about everything imaginable. Interesting point to consider, I have two softphone extensions running on two different computers and haven’t experienced any issues with these extensions. I would think if it was something with my network config or my FreePBX config, the softphones would experience issues as well.

Just offering my own experience to let you know you’re not alone. Still haven’t resolved the issue with the new S300. Considering purchasing an S400 or S500, but reluctant to spend the money because I’m not sure the issue is specific to the S300 or global to all Sangoma phones.

Wish I had a resolution.

Have a great day.

Tony


#4

Anything you can pull from the phones logs via the web interface?

Is it also possible to telnet or ssh into the phone and get a live list of events?


(Tony Smiraldi) #5

I had submitted the phone’s logs and config files to Sangoma for their review. They said everything looked fine and suggested the issue was with my network. They suggested I purchase the paid support option to further troubleshoot the issue.


#6

If the issue is with your network then I doubt the paid support plan will help.

Can you send the s300 that’s acting up for testing to someone else close by who also uses FreePBX?

Also, have you tried provisioning it manually (phone’s web interface) instead of through EPM? Even, if you can’t get the phone apps to work this way you can get the phone to register and make/receive calls and then see how it behaves.


(Tony Lewis) #7

What version of firmware are you using?


(Tony Smiraldi) #8

2.0.4.27


(Tony Smiraldi) #9

Follow up to this issue. After several troubleshooting steps with Sangoma, sending the phone’s logs & config files, and several tweaks to my network config, nothing seemed to resolve the issue of locking up & rebooting. Suggestions were being made that the issue is pointing to my network. I didn’t believe this to be true seeing as the other two softphone extensions are not impacted. So, I decided to purchase another VOIP phone from a different vendor. Plugged this new phone into the same network switch, configured the extension in FreePBX and began to monitor. Each day when the S300 locked up & rebooted itself, this other IP phone remained in service without interruption. This is the second S300 that I’ve experienced the same exact issue. Maybe there is an non-documented issue with this model.


(Tony Lewis) #10

I am.nitnaure what to tell you but we have over 25k of these same model phones throughout the world with very few issues being reported and only 1 other issue being reported in support and our bug tracker about something similar to this and was resolved by customer as a switch issue.


(Tony Smiraldi) #11

I hear what you’re saying Tony. Wish I knew what’s going on. I’m trying one more thing. That is to disable Redirection under Zero Touch Configuration in the Sangoma Portal & remove the Extension Mapping in my FreePBX, then config the phone manually. At this point, I’m just taking a long shot thinking maybe it has something to do with either zero touch provisioning or the Sangoma Template in the Endpoint Manager. Let’s see if the problem persists or stops.

Have a good weekend.


(Tony Smiraldi) #12

Hi Tony,

So here’s another update.The S300 has been operating fine for this whole week since I disabled Zero Touch Configuration in the Sangoma Portal, removed the Extension Mapping in FreePBX, then manually configured the phone using the phone’s GUI. Any ideas? Could it be the Sangoma template in FreePBX, the Zero Touch Configuration, or a combination of both? In any event, I have the S300 up & running pretty stable now. Would still love to know what was causing the daily freeze & reboot.

Have a good weekend.

Tony


(Tony Lewis) #13

Well it can’t be the redirect server as it only hits that once at boot when factory reset. I suggest adding it back to EPM and manually point it at the PBX for config.


(Stefan Liber) #14

Tony,

I have purchased 20 s500 in late April, early May. I have experienced exactly the same issue with 3 of them. They worked fine for a few weeks after which they proceeded to lock and reboot hundreds of times a day. In my case the buggy phones also cause high network traffic between them and the FreePBX box (GBs every 5 minutes or so).

Edit: not several, but hundreds of times a day (every 5 to 15 minutes).


(Tony Smiraldi) #15

Hi Stefan,

It’s been three weeks now since I reset the phone to factory defaults, then configured the phone manually using the phone’s GUI. It’s been flawless ever since. So, what I’ve taken away from this is my issue had to do with the phone receiving it’s config from the template in the FreePBX server. In any event, the phone has not frozen since. I’m leaving well enough alone. I guess I could make the effort to troubleshoot, maybe try a new template etc, but it’s just not that important to me. I’m not deploying a large number of Sangoma phones at this time.

Thanks for your reply. If nothing else, it’s good to know that I’m not the only one experiencing this issue. Sangoma support claims they have 25K of the S300s in service and has not heard of this before.

Have a great day.

Tony


(Tony Lewis) #16

In support we have had very few complaints on this. A few isolated issues but always related to a network, POE or phone config issue with overrides the customer did. If you have a booting issue please open a support ticket. Phones receive free support from support.sangoma.com


(Tony Lewis) #17

Tony

I urge you to move this back to EPM and report if you still have a issue. I really doubt it was related to that and also make sure you are on a updated modern firmware.