Sangoma remote phones don't connect

I decided to try to make life easier and purchase Sangoma phones for my remote users. They’re supposed to be nearly plug-n-play with FreePBX so I thought I’d give it a try.

When the phones arrived I registered them with my Sangoma account in the Customer portal.

I had to make changes to my FreePBX unit first as it used to all be inside my firewall but for these remotes to work, I understand it needs to be in the DMZ so I put it there. I ran the Responsive Firewall wizard and it settled with SIP, Legacy SIP, and IAX all set to Disabled. It placed eth0 in an External zone and my internal IP showing. Eth1 is not used. It shows my entire internal network as a Trusted Network.

I then went to the Endpoint Manager using the free on for Sangoma phones and set up a couple of templates. I plugged in the phones to my internal network and did a scan. Found them. Mapped them to a template. They now show the correct extension in the “Used by” under the Endpoint Manager.

However, the phones don’t work. They’ve pulled an IP but they can’t dial another extension, call out, nor be called. They don’t appear to have downloaded the provisioning from the Endpoint Manager as button definitions etc. didn’t change either.

Thinking it might be because I put them on my internal network I moved one of them to an external IP on a different network and rebooted it. It comes up just like it did on my internal network.

Any suggestions?

You need to tell the phone how to reach the PBX the first time so they can get their configs.

You can pick from any of the 3 options here

There isn’t a Phone Apps tab on the Group Details. It goes from Rest API to VPN.

The quick start guide says you have to run the commercial version of Endpoint Manager but in other places it says there’s an exception if you are using Sangoma phones that you don’t need the commercial version. I’m trying to get Sangoma phones to connect.

I’m using the redirect service of my customer portal to point the phone to the PBX so I’m using option 1 for auto provisioning.

This indicates that your modules need updating.

You must have the commercial EPM installed and up to date. If you are only provisioning Sangoma phones,you do not need a paid license, but the module must be installed and up to date.

I was up to date but I see there’s a new upgrade to the Endpoint manager that was released yesterday that I didn’t have. I updated to the just released version but still no Phone apps. tab in Group Details.

I also see the Phone Apps module has a new update yesterday too. That module is disabled which of course gets my attention. Do I need to purchase that before I can use the auto provision feature on the Sangoma phones? Is that why the Phone Apps tab is missing from the group details?

I’ve not read anywhere that the Phone Apps module needs to be purchased.


Phone Apps are free for Sangoma Phones.

Oh geez. It was disabled by default and I thought I had to click the buy button to enable it since it’s a commercial package.