Sangoma phones not checking in


(ledoktre) #1

Hey all,

My first post, my first purchase. I bought a few S705 phones new within the past month. I’m plugging in a few of them trying to get them to provision through the portal/EPM.

I have the phones all associated with the deployment ID, and I have the information typed in for the provisioning server.

The polling column is not incriminating in the portal, and the phones are not prompting me for login.

The phones are getting dhcp from the same dhcp my computer is. Computer surfs fine. I can see the ip, gateway, and dns on phones are correct. I can log into the phones web url as well.

I question if somehow it’s the settings I typed into the phone tab on the portal (even though I’ve double and triple checked it), yet on online videos showing how to do this, the polling columns count up, even without having the settings configured.

What could be preventing the phones from reaching the sangoma provisioning servers?

Thanks,

Noob


(Itzik) #2

In short. You need to do the following:

  1. Create a Sangoma s705 template.
  2. Map all devices in extension mapping.
  3. In the Sangoma portal, enter the redirection provisioning protocol, address and port.
    If you are using a WAN address, make sure that the ports are forwarded.

Wiki for more details: https://wiki.freepbx.org/display/phon/auto-provision+quick+start+guide


(Lorne Gaetz) #3

If the poll count doesn’t change, then there is something preventing the phones from reaching the zero touch server. There may be a DHCP option 66 string or no route to the internet. If there is an option66 string, then you can manually configure the phones to ignore that and use the zero touch.


(ledoktre) #4

Thanks for your thoughts. I believe I have everything already entered correctly - but even before the portal configuration, it is not increasing the poll count. In a video I watched about configuring the zero touch feature on YT, it showed a phone that had been claimed in the portal, no other setup done yet, and it was increasing the polls. Logics would tell me something lower level is not working right.


(ledoktre) #5

Thanks Igaetz.

I started thinking about what is on my network, how my firewall is configured. The only thing I have setup on my DHCP (its a pfSense box) is network/pxe booting).

I just took a screen shot of that configuration and removed it. I am rebooting the phone, hoping it might have something to do with it.

Thanks for your ideas.


(ledoktre) #6

To follow up - I had just barely posted the comment, and I tested out the theory. Sure enough, removing network/pxe booting configuration and the phone is calling the mother ship just like its supposed to, and I have the login buttons.

Hopefully this helps someone else out there. Big should out and thanks to @lgaetz and @PitzKey !


(system) closed #7

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.