Sangoma Phone Stuck Connecting


I have a user (4001) that is able to login to UCP, login to Sangoma Connect (mobile), but recently is no longer able to login to Sangoma Phone (desktop). The screen is just stuck on “Connecting”.

I’ve tried reinstalling Sangoma Phone, but the same happens.

I’ve also noticed that the WebRTC phone in UCP is showing “Phone: Disconnected” which it never has before.

Has anyone run into this before?


I’d make sure there isn’t any issue with webrtc. Run ‘asterisk-version-switch’ to make sure you are running the latest Asterisk v18 release (do it after hours, it will drop calls). If it is still not working, open up a support ticket.

1 Like

Don’t use http:// or https:// at the login screen. You may need to reinstall the app to kill the “connecting…” session and then try again.

1 Like

FreePBX is version 16.0.33 running Asterisk 18.16.0.

I’ve tried to connect with and without the https:// at the beginning of the URL and just get an endless loop of connecting. FreePBX is running in the cloud on Vultr using the FreePBX responsive firewall. I’m trying to connect from a trusted network so it should be fine (and was working fine up until about a week ago).

I noticed that none of the WebRTC extensions from UCP are connecting either, but my sip desk phones and Sangoma Connect mobile app are all connecting fine.

Is there anything I can check on the WebRTC end? I found the Wiki for WebRTC, but it’s dated 2014 and looks like it needs to be updated so I’m not sure if there is something I’m missing.


This is now resolved. The solution was to remove the 0 from the HTTP Prefix field in advance settings. The 0 was added by a recent yum update. Someone at Sangoma needs to take a look at the last couple of Asterisk updates.

More on the resolution here:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.